summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2016-04-25 22:59:19 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-17 14:42:17 +0100
commit1b5b831d1bbb92760ce01b38347cf0bcaa1bb59f (patch)
tree97cf1fe465ffdedecb6e0e6def6f1906e3a094f2 /meta/recipes-core/coreutils
parenta3d223284854a21c84e8f6d075d23b32789afa01 (diff)
downloadopenembedded-core-1b5b831d1bbb92760ce01b38347cf0bcaa1bb59f.tar.gz
coreutils: fix for native and nativesdk
The do_install_append is used for moving/renaming for ALTERNATIVE, but it breaks native, for example there is no ln, but ln.coreutils, that makes coreutils-native don't work. This patch fixes the problem. Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/coreutils')
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.25.bb14
1 files changed, 9 insertions, 5 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.25.bb b/meta/recipes-core/coreutils/coreutils_8.25.bb
index 419a693372..b1aaf539fb 100644
--- a/meta/recipes-core/coreutils/coreutils_8.25.bb
+++ b/meta/recipes-core/coreutils/coreutils_8.25.bb
@@ -69,6 +69,15 @@ do_compile_prepend () {
mkdir -p ${B}/src
}
+do_install_class-native() {
+ autotools_do_install
+ # remove groups to fix conflict with shadow-native
+ rm -f ${D}${STAGING_BINDIR_NATIVE}/groups
+ # The return is a must since native doesn't need the
+ # do_install_append() in the below.
+ return
+}
+
do_install_append() {
for i in df mktemp base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done
@@ -91,11 +100,6 @@ do_install_append() {
cp -a ${D}${mandir}/man1/test.1 ${D}${mandir}/man1/lbracket.1.${BPN}
}
-do_install_append_class-native(){
- # remove groups to fix conflict with shadow-native
- rm -f ${D}${STAGING_BINDIR_NATIVE}/groups
-}
-
inherit update-alternatives
ALTERNATIVE_PRIORITY = "100"