summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/base-passwd
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-core/base-passwd
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadopenembedded-core-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/base-passwd')
-rw-r--r--meta/recipes-core/base-passwd/base-passwd-3.5.22/mysql.patch13
-rw-r--r--meta/recipes-core/base-passwd/base-passwd-3.5.22/nobash.patch20
-rw-r--r--meta/recipes-core/base-passwd/base-passwd-3.5.22/root-home.patch11
-rw-r--r--meta/recipes-core/base-passwd/base-passwd_3.5.22.bb50
4 files changed, 94 insertions, 0 deletions
diff --git a/meta/recipes-core/base-passwd/base-passwd-3.5.22/mysql.patch b/meta/recipes-core/base-passwd/base-passwd-3.5.22/mysql.patch
new file mode 100644
index 0000000000..8bfd757929
--- /dev/null
+++ b/meta/recipes-core/base-passwd/base-passwd-3.5.22/mysql.patch
@@ -0,0 +1,13 @@
+# set correct uid/gid for mysql, from OE (8836cd807198c224ed23b05fa4f708f096881b27).
+# however poky doesn't include mysql so far. Remove it from patch list, but keep
+# this patch for a while
+#
+# comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-06
+--- base-passwd/group.master.orig 2005-07-08 06:36:07.717990112 +0200
++++ base-passwd/group.master 2005-07-08 06:36:32.000000000 +0200
+@@ -36,4 +36,5 @@
+ staff:*:50:
+ games:*:60:
+ users:*:100:
++mysql:*:64001:
+ nogroup:*:65534:
diff --git a/meta/recipes-core/base-passwd/base-passwd-3.5.22/nobash.patch b/meta/recipes-core/base-passwd/base-passwd-3.5.22/nobash.patch
new file mode 100644
index 0000000000..52650166f8
--- /dev/null
+++ b/meta/recipes-core/base-passwd/base-passwd-3.5.22/nobash.patch
@@ -0,0 +1,20 @@
+# use /bin/sh instead of /bin/bash, since the latter may not be included in
+# some images such as minimal
+#
+# comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-06
+#
+# remove "*" for root since we don't have a /etc/shadow so far.
+#
+# by Kevin Tian <kevin.tian@intel.com>, 2010-07-06
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- base-passwd/passwd.master~nobash
++++ base-passwd/passwd.master
+@@ -1,4 +1,4 @@
+-root:*:0:0:root:/root:/bin/bash
++root::0:0:root:/root:/bin/sh
+ daemon:*:1:1:daemon:/usr/sbin:/bin/sh
+ bin:*:2:2:bin:/bin:/bin/sh
+ sys:*:3:3:sys:/dev:/bin/sh
diff --git a/meta/recipes-core/base-passwd/base-passwd-3.5.22/root-home.patch b/meta/recipes-core/base-passwd/base-passwd-3.5.22/root-home.patch
new file mode 100644
index 0000000000..87c4655a04
--- /dev/null
+++ b/meta/recipes-core/base-passwd/base-passwd-3.5.22/root-home.patch
@@ -0,0 +1,11 @@
+# poky uses /home/root instead of /root.
+#
+# comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-06
+--- base-passwd/passwd.master.orig 2005-07-08 06:26:22.000000000 +0200
++++ base-passwd/passwd.master 2005-07-08 06:31:58.000000000 +0200
+@@ -1,4 +1,4 @@
+-root::0:0:root:/root:/bin/sh
++root::0:0:root:/home/root:/bin/sh
+ daemon:*:1:1:daemon:/usr/sbin:/bin/sh
+ bin:*:2:2:bin:/bin:/bin/sh
+ sys:*:3:3:sys:/dev:/bin/sh
diff --git a/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb b/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
new file mode 100644
index 0000000000..f0ca8e6280
--- /dev/null
+++ b/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
@@ -0,0 +1,50 @@
+DESCRIPTION = "Base system password/group files."
+SECTION = "base"
+PR = "r0"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/b/base-passwd/base-passwd_${PV}.tar.gz \
+ file://nobash.patch \
+ file://root-home.patch"
+
+S = "${WORKDIR}/base-passwd"
+
+inherit autotools
+
+do_install () {
+ install -d -m 755 ${D}${sbindir}
+ install -p -m 755 update-passwd ${D}${sbindir}/
+ install -d -m 755 ${D}${mandir}/man8 ${D}${mandir}/pl/man8
+ install -p -m 644 man/update-passwd.8 ${D}${mandir}/man8/
+ install -p -m 644 man/update-passwd.pl.8 \
+ ${D}${mandir}/pl/man8/update-passwd.8
+ gzip -9 ${D}${mandir}/man8/* ${D}${mandir}/pl/man8/*
+ install -d -m 755 ${D}${datadir}/base-passwd
+ install -p -m 644 passwd.master ${D}${datadir}/base-passwd/
+ install -p -m 644 group.master ${D}${datadir}/base-passwd/
+
+ install -d -m 755 ${D}${docdir}/${PN}
+ install -p -m 644 debian/changelog ${D}${docdir}/${PN}/
+ gzip -9 ${D}${docdir}/${PN}/*
+ install -p -m 644 README ${D}${docdir}/${PN}/
+ install -p -m 644 debian/copyright ${D}${docdir}/${PN}/
+}
+
+do_install_append_openmn() {
+ echo "0:Jn6tcg/qjqvUE:0:0:root:/root:/bin/sh" >>${D}${datadir}/base-passwd/passwd.master
+}
+
+
+pkg_postinst () {
+ set -e
+
+ if [ ! -e $D${sysconfdir}/passwd ] ; then
+ cp $D${datadir}/base-passwd/passwd.master $D${sysconfdir}/passwd
+ fi
+
+ if [ ! -e $D${sysconfdir}/group ] ; then
+ cp $D${datadir}/base-passwd/group.master $D${sysconfdir}/group
+ fi
+ exit 0
+}