summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/base-files
diff options
context:
space:
mode:
authorMartin Donnelly <martin.donnelly@ge.com>2013-01-19 22:47:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-20 12:45:55 +0000
commit77bbb839ba25b974a538b90d346b454ccd5deefd (patch)
treef660a26e530f000febae5211032b05100fce22a3 /meta/recipes-core/base-files
parenteaa82c842d3197e0251a887ba16028c22f9d8d94 (diff)
downloadopenembedded-core-77bbb839ba25b974a538b90d346b454ccd5deefd.tar.gz
base-files: add fstab for systemd based systems
The default fstab has entries which are not necessary in systemd based systems so add a simpler default in this case. Signed-off-by: Martin Donnelly <martin.donnelly@ge.com> Signed-off-by: Radu Moisan <radu.moisan@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/base-files')
-rw-r--r--meta/recipes-core/base-files/base-files/fstab.systemd9
-rw-r--r--meta/recipes-core/base-files/base-files_3.0.14.bb7
2 files changed, 15 insertions, 1 deletions
diff --git a/meta/recipes-core/base-files/base-files/fstab.systemd b/meta/recipes-core/base-files/base-files/fstab.systemd
new file mode 100644
index 0000000000..cb48a0de4a
--- /dev/null
+++ b/meta/recipes-core/base-files/base-files/fstab.systemd
@@ -0,0 +1,9 @@
+# stock fstab - you probably want to override this with a machine specific one
+
+rootfs / auto defaults 1 1
+tmpfs /var/volatile tmpfs defaults 0 0
+tmpfs /media/ram tmpfs defaults 0 0
+
+# uncomment this if your device has a SD/MMC/Transflash slot
+#/dev/mmcblk0p1 /media/card auto defaults,sync,noauto 0 0
+
diff --git a/meta/recipes-core/base-files/base-files_3.0.14.bb b/meta/recipes-core/base-files/base-files_3.0.14.bb
index 8ef71958b0..a90e995932 100644
--- a/meta/recipes-core/base-files/base-files_3.0.14.bb
+++ b/meta/recipes-core/base-files/base-files_3.0.14.bb
@@ -18,6 +18,7 @@ SRC_URI = "file://rotation \
file://profile \
file://shells \
file://fstab \
+ file://fstab.systemd \
file://filesystems \
file://issue.net \
file://issue \
@@ -91,7 +92,11 @@ do_install () {
install -m 0644 ${WORKDIR}/rotation ${D}${sysconfdir}/rotation
fi
- install -m 0644 ${WORKDIR}/fstab ${D}${sysconfdir}/fstab
+ if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -m 0644 ${WORKDIR}/fstab.systemd ${D}${sysconfdir}/fstab
+ else
+ install -m 0644 ${WORKDIR}/fstab ${D}${sysconfdir}/fstab
+ fi
install -m 0644 ${WORKDIR}/filesystems ${D}${sysconfdir}/filesystems
install -m 0644 ${WORKDIR}/usbd ${D}${sysconfdir}/default/usbd
sed -i "s#ROOTHOME#${ROOT_HOME}#" ${WORKDIR}/profile