summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-04-10 18:20:35 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-13 22:28:35 +0100
commitc64c9f7ffc88018404afdde373dfd7ef2bdf7ae8 (patch)
treeb45faf310e6db37feb285d53bcd5e33cd4a7705c /meta/recipes-connectivity
parent615ade48bfb8f1d1287e4ec79f4e2f4b610bdb5b (diff)
downloadopenembedded-core-c64c9f7ffc88018404afdde373dfd7ef2bdf7ae8.tar.gz
ppp: Add extra include dirs
Just run configure, the configure script is not really a autoconf generated script so just run it Include path is needed to be there since the headers from it are used during build in subcomponents Change-Id: Ib1f24fd18bc8564e3c74ab834b7cf0fdf955d0e1 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/ppp/ppp_2.4.7.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/ppp/ppp_2.4.7.bb b/meta/recipes-connectivity/ppp/ppp_2.4.7.bb
index 92ca0c92c6..4219d45591 100644
--- a/meta/recipes-connectivity/ppp/ppp_2.4.7.bb
+++ b/meta/recipes-connectivity/ppp/ppp_2.4.7.bb
@@ -43,7 +43,11 @@ EXTRA_OECONF = "--disable-strip"
# Package Makefile computes CFLAGS, referencing COPTS.
# Typically hard-coded to '-O2 -g' in the Makefile's.
#
-EXTRA_OEMAKE += ' COPTS="${CFLAGS}"'
+EXTRA_OEMAKE += ' COPTS="${CFLAGS} -I${S}/include"'
+
+do_configure () {
+ oe_runconf
+}
do_install_append () {
make install-etcppp ETCDIR=${D}/${sysconfdir}/ppp