aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/wireless-tools/wireless-tools
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-02-15 20:59:49 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-23 23:59:14 +0000
commitca343882f8e95b49b18b234000e387c879cf5885 (patch)
tree3078413fcf36a1a19fd801d4fa7966f7c7c529af /meta/recipes-connectivity/wireless-tools/wireless-tools
parent5aab6653c9afa05e7c1b3ccd6bd34aec05c2a6f8 (diff)
downloadopenembedded-core-ca343882f8e95b49b18b234000e387c879cf5885.tar.gz
wireless-tools: remove ldconfig call from install-libs
* and drop apply=yes param as it's not needed Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-connectivity/wireless-tools/wireless-tools')
-rw-r--r--meta/recipes-connectivity/wireless-tools/wireless-tools/remove.ldconfig.call.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/wireless-tools/wireless-tools/remove.ldconfig.call.patch b/meta/recipes-connectivity/wireless-tools/wireless-tools/remove.ldconfig.call.patch
new file mode 100644
index 0000000000..3a22c3f1e7
--- /dev/null
+++ b/meta/recipes-connectivity/wireless-tools/wireless-tools/remove.ldconfig.call.patch
@@ -0,0 +1,19 @@
+When /etc/ld.so.cache is writeable by user running bitbake then it creates invalid cache
+(in my case libstdc++.so cannot be found after building zlib(-native) and I have to call
+touch */libstdc++.so && /sbin/ldconfig to fix it.
+
+So remove ldconfig call from make install-libs
+
+Upstream-Status: Inappropriate [disable feature]
+
+diff -uNr wireless_tools.29.orig/Makefile wireless_tools.29/Makefile
+--- wireless_tools.29.orig/Makefile 2007-09-18 01:56:46.000000000 +0200
++++ wireless_tools.29/Makefile 2012-02-15 20:46:41.780763514 +0100
+@@ -163,7 +163,6 @@
+ install -m 755 $(DYNAMIC) $(INSTALL_LIB)
+ ln -sfn $(DYNAMIC) $(INSTALL_LIB)/$(DYNAMIC_LINK)
+ @echo "*** Don't forget to add $(INSTALL_LIB) to /etc/ld.so.conf, and run ldconfig as root. ***"
+- @$(LDCONFIG) || echo "*** Could not run ldconfig ! ***"
+
+ # Install the static library
+ install-static:: $(STATIC)