aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/socat/socat_1.7.2.0.bb
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2011-12-19 13:17:46 +0800
committerSaul Wold <sgw@linux.intel.com>2011-12-21 23:50:22 -0800
commitb1771ff0ad39250678bd53b0ae7543c9365572f5 (patch)
tree929eeace6a79954e2f1a9473db86873459bb5233 /meta/recipes-connectivity/socat/socat_1.7.2.0.bb
parent9917aca0a559453dee6fd7c544e3cf54333215cb (diff)
downloadopenembedded-core-b1771ff0ad39250678bd53b0ae7543c9365572f5.tar.gz
socat: add the latest stable version 1.7.2.0
socat is useful for the self-hosted-image work. The original recipe is from OE: http://git.openembedded.org/openembedded/tree/recipes/socat/ and I upgraded it to 1.7.2.0. Thank Koen Kooi <koen@dominion.thruhere.net> for suggesting how to assign the LICENSE field with a proper value. Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Diffstat (limited to 'meta/recipes-connectivity/socat/socat_1.7.2.0.bb')
-rw-r--r--meta/recipes-connectivity/socat/socat_1.7.2.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/socat/socat_1.7.2.0.bb b/meta/recipes-connectivity/socat/socat_1.7.2.0.bb
new file mode 100644
index 0000000000..1273dcf0f2
--- /dev/null
+++ b/meta/recipes-connectivity/socat/socat_1.7.2.0.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Socat is a relay for bidirectional data \
+transfer between two independent data channels."
+HOMEPAGE = "http://www.dest-unreach.org/socat/"
+
+SECTION = "console/network"
+
+DEPENDS = "openssl"
+
+LICENSE = "GPL-2.0+-with-OpenSSL-exception"
+
+PR = "r0"
+SRC_URI = "http://www.dest-unreach.org/socat/download/socat-${PV}.tar.bz2;name=src \
+ file://compile.patch"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760 \
+ file://README;beginline=252;endline=282;md5=79246f11a1db0b6ccec54d1fb711c01e"
+
+SRC_URI[src.md5sum] = "eb563dd00b9d39a49fb62a677fc941fe"
+SRC_URI[src.sha256sum] = "59b3bde927c14fbc3f9e42c782971710da8a89bbf46f7531f09a681754041802"
+
+EXTRA_OECONF = " --disable-termios "
+
+inherit autotools
+
+do_install_prepend () {
+ mkdir -p ${D}${bindir}
+ install -d ${D}${bindir} ${D}${mandir}/man1
+}