aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/iproute2
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-03-01 09:13:44 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-04 10:08:02 +0000
commit08be60d903ee97859295387b3418d5db85ab16e1 (patch)
tree2a96c76597fdda782ee86057f207704d347a27c5 /meta/recipes-connectivity/iproute2
parentbe40f6d0bb80274366af00461112af65687a4de8 (diff)
downloadopenembedded-core-08be60d903ee97859295387b3418d5db85ab16e1.tar.gz
iproute2: Fix build failure on ppc
Latest version bump started failing for ppc32 attached patch is a backport from 3.9-rc1 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/iproute2')
-rw-r--r--meta/recipes-connectivity/iproute2/iproute2/0001-Fix-compilation-error-of-m_ipt.c-with-Werror-enabled.patch46
-rw-r--r--meta/recipes-connectivity/iproute2/iproute2_3.8.0.bb6
2 files changed, 50 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/iproute2/iproute2/0001-Fix-compilation-error-of-m_ipt.c-with-Werror-enabled.patch b/meta/recipes-connectivity/iproute2/iproute2/0001-Fix-compilation-error-of-m_ipt.c-with-Werror-enabled.patch
new file mode 100644
index 0000000000..db74963e48
--- /dev/null
+++ b/meta/recipes-connectivity/iproute2/iproute2/0001-Fix-compilation-error-of-m_ipt.c-with-Werror-enabled.patch
@@ -0,0 +1,46 @@
+Upstream-Status: Backport
+
+From 9235195666af7d887771cf557ef2bd3f00b9ecc8 Mon Sep 17 00:00:00 2001
+From: Vijay Subramanian <subramanian.vijay@gmail.com>
+Date: Tue, 26 Feb 2013 09:12:07 +0000
+Subject: [PATCH] Fix compilation error of m_ipt.c with -Werror enabled
+
+Commit (5a650703d47e10aa386406c855eff5a593b2120b Makefile: make warnings into
+errors ) causes the following build error.
+
+gcc -Wall -Wstrict-prototypes -Werror -Wmissing-prototypes
+-Wmissing-declarations -Wold-style-definition -O2 -I../include
+-DRESOLVE_HOSTNAMES -DLIBDIR=\"/usr/lib\" -DCONFDIR=\"/etc/iproute2\"
+-D_GNU_SOURCE -DCONFIG_GACT -DCONFIG_GACT_PROB -DIPT_LIB_DIR=\"/lib/xtables\"
+-DYY_NO_INPUT -c -o m_ipt.o m_ipt.c
+cc1: warnings being treated as errors
+m_ipt.c:72: error: no previous prototype for 'xtables_register_target'
+m_ipt.c:361: error: no previous prototype for 'build_st'
+make[1]: *** [m_ipt.o] Error 1
+
+This is fixed by adding the prototype in the header include/iptables.h
+
+I am not sure if this is due to something wrong on my build system but I am
+using current glibc 2.17.
+
+Signed-off-by: Vijay Subramanian <subramanian.vijay@gmail.com>
+---
+ include/iptables.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/include/iptables.h b/include/iptables.h
+index dd844c1..f1e62e2 100644
+--- a/include/iptables.h
++++ b/include/iptables.h
+@@ -143,6 +143,8 @@ extern int line;
+ /* Your shared library should call one of these. */
+ extern void register_match(struct iptables_match *me);
+ extern void register_target(struct iptables_target *me);
++extern void xtables_register_target(struct iptables_target *me);
++extern int build_st(struct iptables_target *target, struct ipt_entry_target *t);
+
+ extern struct in_addr *dotted_to_addr(const char *dotted);
+ extern char *addr_to_dotted(const struct in_addr *addrp);
+--
+1.7.9.5
+
diff --git a/meta/recipes-connectivity/iproute2/iproute2_3.8.0.bb b/meta/recipes-connectivity/iproute2/iproute2_3.8.0.bb
index 70dcd2dc43..892d230062 100644
--- a/meta/recipes-connectivity/iproute2/iproute2_3.8.0.bb
+++ b/meta/recipes-connectivity/iproute2/iproute2_3.8.0.bb
@@ -1,9 +1,11 @@
require iproute2.inc
-PR = "r0"
+PR = "r1"
SRC_URI = "${KERNELORG_MIRROR}/linux/utils/net/${BPN}/${BPN}-${PV}.tar.xz \
- file://configure-cross.patch"
+ file://configure-cross.patch \
+ file://0001-Fix-compilation-error-of-m_ipt.c-with-Werror-enabled.patch \
+ "
SRC_URI[md5sum] = "951622fd770428116dc165acba375414"
SRC_URI[sha256sum] = "579145749f1aaf60e7c7a5de24b7f00fa2200a961094733c792b4ff139181e4f"