aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/dhcp
diff options
context:
space:
mode:
authorAwais Belal <awais_belal@mentor.com>2016-01-12 14:55:03 +0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-13 00:03:52 +0000
commita9e4edb2b5304e7493b791f3b3f76d37af5433ff (patch)
tree5d2a5569b6aac130e0b3cc093309f4d9587a3bce /meta/recipes-connectivity/dhcp
parent1dec024b020b04375bc80df5c722a62e63ff7732 (diff)
downloadopenembedded-core-a9e4edb2b5304e7493b791f3b3f76d37af5433ff.tar.gz
dhcp: search libxml2 for bind
libdns requires libxml2 if bind was built with libxml2 support enabled. Compilation will fail for omapip/test.c in case -lxml2 isn't used during the build. So, we add losely coupled search path which will pick up the lib if it is present. Signed-off-by: Awais Belal <awais_belal@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/dhcp')
-rw-r--r--meta/recipes-connectivity/dhcp/dhcp.inc3
-rw-r--r--meta/recipes-connectivity/dhcp/dhcp/search-for-libxml2.patch23
2 files changed, 25 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/dhcp/dhcp.inc b/meta/recipes-connectivity/dhcp/dhcp.inc
index a673dbc878..9c4233b19d 100644
--- a/meta/recipes-connectivity/dhcp/dhcp.inc
+++ b/meta/recipes-connectivity/dhcp/dhcp.inc
@@ -18,7 +18,8 @@ SRC_URI = "ftp://ftp.isc.org/isc/dhcp/${PV}/dhcp-${PV}.tar.gz \
file://init-server file://default-server \
file://dhclient.conf file://dhcpd.conf \
file://dhcpd.service file://dhcrelay.service \
- file://dhcpd6.service "
+ file://dhcpd6.service \
+ file://search-for-libxml2.patch "
UPSTREAM_CHECK_URI = "ftp://ftp.isc.org/isc/dhcp/"
UPSTREAM_CHECK_REGEX = "(?P<pver>\d+\.\d+\.(\d+?))/"
diff --git a/meta/recipes-connectivity/dhcp/dhcp/search-for-libxml2.patch b/meta/recipes-connectivity/dhcp/dhcp/search-for-libxml2.patch
new file mode 100644
index 0000000000..a08a5b725f
--- /dev/null
+++ b/meta/recipes-connectivity/dhcp/dhcp/search-for-libxml2.patch
@@ -0,0 +1,23 @@
+libdns requires libxml2 if bind was built with libxml2 support
+enabled. Compilation will fail for omapip/test.c in case
+lxml2 isn't used during the build. So, we add losely coupled
+search path which will pick up the lib if it is present.
+
+Signed-off-by: Awais Belal <awais_belal@mentor.com>
+Upstream-Status: Pending
+
+diff --git a/configure.ac b/configure.ac
+index c9dc8b5..85f59be 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -602,6 +602,10 @@ no)
+ esac
+ AC_SUBST([libbind])
+
++# We need to find libxml2 if bind was built with support enabled
++# otherwise we'll fail to build omapip/test.c
++AC_SEARCH_LIBS(xmlTextWriterStartElement, [xml2],)
++
+ # OpenLDAP support.
+ AC_ARG_WITH(ldap,
+ AS_HELP_STRING([--with-ldap],[enable OpenLDAP support in dhcpd (default is no)]),