aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/connman/connman.inc
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-12-09 20:01:33 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-10 00:03:59 +0000
commitdb692fd5706eab9bfd94c115591d1411cf8e196e (patch)
treeeb4a1c46d62041c9ea6a3d55e3b98d261207b281 /meta/recipes-connectivity/connman/connman.inc
parentc67d7c9215bd8af2b5dcc4a72b6edf00157724d5 (diff)
downloadopenembedded-core-db692fd5706eab9bfd94c115591d1411cf8e196e.tar.gz
connman: avoid checking for linux/if_alg.h header
Disable building of 'alg-test' and checking for if_alg.h header. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/connman/connman.inc')
-rw-r--r--meta/recipes-connectivity/connman/connman.inc8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/connman/connman.inc b/meta/recipes-connectivity/connman/connman.inc
index d695fee218..503bf1cffa 100644
--- a/meta/recipes-connectivity/connman/connman.inc
+++ b/meta/recipes-connectivity/connman/connman.inc
@@ -49,6 +49,14 @@ USERADD_PARAM_${PN} = "--system --no-create-home \
inherit autotools pkgconfig update-rc.d useradd
+# alg-test doesn't build, so disable that and test
+# for if_alg.h as this header is only in 2.6.39
+do_configure_prepend() {
+ sed -i 's:tools/alg-test ::g' Makefile.am
+ sed -i 's:AC_CHECK_HEADERS(linux/if_alg.h, dummy=yes,::g;
+ s:AC_MSG_ERROR(User-space algorithm header files are required))::g' configure.ac
+}
+
do_compile_append() {
sed -i -e s:deny:allow:g src/connman-dbus.conf
}