aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/connman/connman-conf.bb
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2013-03-04 19:17:50 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-07 11:06:05 +0000
commit5711e0cf88fac0de8a5317b16a287b335c827c8f (patch)
tree28872f4f2d5dd38a218d32e0750acb1c2f13086b /meta/recipes-connectivity/connman/connman-conf.bb
parentbd94ab11bbb6501013ed27ecb22685664816986c (diff)
downloadopenembedded-core-5711e0cf88fac0de8a5317b16a287b335c827c8f.tar.gz
connman: Wired inteface provisioned via qemu
- connman-conf package re-implemented - connman 1.12 introduces provisioning for wired interfaces also; - wired interface settings are read from kernel cmdline if present; - after that are passed to connman as a config file - for BA, this is not needed, as BA will have a network infrastructure to work with. Fixes [YOCTO #3227]; Fixes [YOCTO #3804]; Fixes [YOCTO #3843]. Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-connectivity/connman/connman-conf.bb')
-rw-r--r--meta/recipes-connectivity/connman/connman-conf.bb17
1 files changed, 10 insertions, 7 deletions
diff --git a/meta/recipes-connectivity/connman/connman-conf.bb b/meta/recipes-connectivity/connman/connman-conf.bb
index 7c7ef263ce..7b999533f1 100644
--- a/meta/recipes-connectivity/connman/connman-conf.bb
+++ b/meta/recipes-connectivity/connman/connman-conf.bb
@@ -1,18 +1,21 @@
-#connman config to ignore wired interfaces on qemu machines
+#connman config to setup wired interface on qemu machines
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-SRC_URI_append_qemuall = " file://main.conf"
-
-PR = "r0"
+SRC_URI_append_qemuall = "file://wired.config \
+ file://wired-setup \
+ "
+PR = "r1"
PACKAGE_ARCH = "${MACHINE_ARCH}"
do_install() {
- #Blacklist ethn network interface in case of qemu* machines
- if test -e ${WORKDIR}/main.conf; then
+ #Configure Wired network interface in case of qemu* machines
+ if test -e ${WORKDIR}/wired.config && test -e ${WORKDIR}/wired-setup; then
+ install -d ${D}${localstatedir}/lib/connman
+ install -m 0644 ${WORKDIR}/wired.config ${D}${localstatedir}/lib/connman
install -d ${D}${sysconfdir}/connman
- install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman
+ install -m 0755 ${WORKDIR}/wired-setup ${D}${sysconfdir}/connman
fi
}