aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/avahi
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2013-06-10 16:15:49 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-11 15:47:35 +0100
commit4599ef630c13224506671bf84569bfc240cd3032 (patch)
tree0400d089816759e2411c017a489b0becfb9e51ef /meta/recipes-connectivity/avahi
parente87232828b761d56f1ce6a27e4009d350d68209c (diff)
downloadopenembedded-core-4599ef630c13224506671bf84569bfc240cd3032.tar.gz
avahi: inherit python classes, use PACKAGECONFIG
Without using our python classes and having appropriate dependencies, the build is nondeterministic, and whether a python-avahi package is produced will vary depending on the host environment, yet avahi-discover is always produced, and it depends on python-avahi. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/avahi')
-rw-r--r--meta/recipes-connectivity/avahi/avahi-ui_0.6.31.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/avahi/avahi-ui_0.6.31.bb b/meta/recipes-connectivity/avahi/avahi-ui_0.6.31.bb
index 7d56dad641..557c1c1651 100644
--- a/meta/recipes-connectivity/avahi/avahi-ui_0.6.31.bb
+++ b/meta/recipes-connectivity/avahi/avahi-ui_0.6.31.bb
@@ -6,6 +6,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
require avahi.inc
+inherit python-dir pythonnative
+
+PACKAGECONFIG ??= "python"
+PACKAGECONFIG[python] = "--enable-python,--disable-python,python-native python"
+
PR = "${INC_PR}.0"
SRC_URI[md5sum] = "2f22745b8f7368ad5a0a3fddac343f2d"
@@ -26,7 +31,7 @@ FILES_${PN}-staticdev += "${libdir}/libavahi-ui.a"
FILES_${PN}-utils = "${bindir}/b* ${datadir}/applications/b*"
-FILES_python-avahi = "${PYTHON_SITEPACKAGES_DIR}/avahi/*"
+FILES_python-avahi = "${PYTHON_SITEPACKAGES_DIR}/avahi ${PYTHON_SITEPACKAGES_DIR}/avahi_discover"
FILES_avahi-discover = "${bindir}/avahi-discover \
${datadir}/applications/avahi-discover.desktop \
${datadir}/avahi/interfaces/avahi-discover*"
@@ -34,7 +39,7 @@ FILES_avahi-discover-standalone = "${bindir}/avahi-discover-standalone \
${datadir}/avahi/interfaces/avahi-discover.glade"
RDEPENDS_avahi-discover = "python-avahi python-pygtk"
-RDEPENDS_python-avahi = "python-dbus"
+RDEPENDS_python-avahi = "python-core python-dbus"
do_install_append () {