summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2017-03-14 15:37:34 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-17 16:52:44 +0000
commit2815f819c1a620949213fa952557c03f7d594ed6 (patch)
tree4bd460e66c927ed70873c24b968b1b3e638681f3 /meta/recipes-bsp
parent13cf0df0252941b9575da613488cbc141e043a8a (diff)
downloadopenembedded-core-2815f819c1a620949213fa952557c03f7d594ed6.tar.gz
u-boot-fw-utils: reuse the same override HOSTCC patch as u-boot-mkimage
Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.01.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.01.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.01.bb
index f56862cb27..26314990b9 100644
--- a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.01.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.01.bb
@@ -1,10 +1,12 @@
require u-boot-common_${PV}.inc
+SRC_URI += "file://default-gcc.patch"
+
SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
DEPENDS = "mtd-utils"
INSANE_SKIP_${PN} = "already-stripped"
-EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
inherit uboot-config