aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-09-07 01:28:36 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-08 00:31:41 +0100
commitd941d66d714545eae589115db48f1243399711f2 (patch)
tree0cfe95c19c52f83f5bec40562dd1f570ce98dda8 /meta/recipes-bsp
parent91d3fce1eb3e27d646afba8cf3c03ae560412d1d (diff)
downloadopenembedded-core-d941d66d714545eae589115db48f1243399711f2.tar.gz
pciutils: fix PACKAGECONFIG
The PACKAGECONFIG's value doens't go into EXTRA_OECONF, but PACKAGECONFIG_CONFARGS. Fixed: pciutils-3.5.1: libpci rdepends on libudev, but it isn't a build dependency, missing eudev in DEPENDS or PACKAGECONFIG? [build-deps] pciutils-3.5.1: pciutils rdepends on libudev, but it isn't a build dependency, missing eudev in DEPENDS or PACKAGECONFIG? [build-deps] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/pciutils/pciutils_3.5.1.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-bsp/pciutils/pciutils_3.5.1.bb b/meta/recipes-bsp/pciutils/pciutils_3.5.1.bb
index a84efd9ced..d32b119424 100644
--- a/meta/recipes-bsp/pciutils/pciutils_3.5.1.bb
+++ b/meta/recipes-bsp/pciutils/pciutils_3.5.1.bb
@@ -27,9 +27,9 @@ PCI_CONF_FLAG = "ZLIB=yes DNS=yes SHARED=yes"
do_configure () {
(
cd lib && \
- # EXTRA_OECONF for this recipe could only possibly contain 'HWDB=yes/no', so we put it
- # before ./configure
- ${PCI_CONF_FLAG} ${EXTRA_OECONF} ./configure ${PV} ${datadir} ${TARGET_OS} ${TARGET_ARCH}
+ # PACKAGECONFIG_CONFARGS for this recipe could only possibly contain 'HWDB=yes/no',
+ # so we put it before ./configure
+ ${PCI_CONF_FLAG} ${PACKAGECONFIG_CONFARGS} ./configure ${PV} ${datadir} ${TARGET_OS} ${TARGET_ARCH}
)
}