aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-12-13 20:00:35 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-09 13:34:31 +0000
commit24325410acb670a3e7bc626ac3607efa8df38dc5 (patch)
treed83f5e0bbc1eb2bb19e377d5c4fbcc7a7dc745c4 /meta/recipes-bsp
parentaf0203f1543e444d4c9397c6b400ba627baf9574 (diff)
downloadopenembedded-core-24325410acb670a3e7bc626ac3607efa8df38dc5.tar.gz
gnu-efi: build 64-bit for x32
We're targeting the x86_64 EFI ABI. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb b/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb
index 9ddc4ba716..e55ab7f059 100644
--- a/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb
+++ b/meta/recipes-bsp/gnu-efi/gnu-efi_3.0.4.bb
@@ -52,3 +52,12 @@ BBCLASSEXTEND = "native"
# CFLAGS += -mno-mmx -mno-sse
# So also remove -mfpmath=sse from TUNE_CCARGS
TUNE_CCARGS_remove = "-mfpmath=sse"
+
+python () {
+ ccargs = d.getVar('TUNE_CCARGS', True).split()
+ if '-mx32' in ccargs:
+ # use x86_64 EFI ABI
+ ccargs.remove('-mx32')
+ ccargs.append('-m64')
+ d.setVar('TUNE_CCARGS', ' '.join(ccargs))
+}