aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2017-05-17 22:11:34 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-04 23:26:56 +0100
commitaab5311f3ad9fb9f9e26b18b5fe5e54d8ec14798 (patch)
treef90e7e29c1a55a434e44d94791e31e100982c13c /meta/recipes-bsp
parent26e25713852ed747a96ce55fe9dc7dd2a4fd250b (diff)
downloadopenembedded-core-aab5311f3ad9fb9f9e26b18b5fe5e54d8ec14798.tar.gz
u-boot-mkimage: fix nativesdk build
If building for nativesdk the wrong rss sysroot is used leading the following error message. | ERROR: oe_runmake failed | In file included from tools/imximage.c:13:0: | include/image.h:1024:27: fatal error: openssl/evp.h: No such file or directory | # include <openssl/evp.h> Tools needed on the build host (script/basic/fixdep) and code compiled for the SDK machine are both built with the build host's compiler, leading to additinal errors. Adding CROSS_COMPILE="${HOST_PREFIX}" and using the cross-compiler for the SDK_ARCH fixes the build error. The resulting binary in the SDK is working. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb
index 1aa95e7c86..de999e7cd5 100644
--- a/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb
@@ -7,7 +7,7 @@ DEPENDS = "openssl"
EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
-EXTRA_OEMAKE_class-nativesdk = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
+EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
do_compile () {
oe_runmake sandbox_defconfig