aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorPhilip Tricca <flihp@twobit.us>2014-04-16 01:16:48 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-23 11:43:09 +0100
commit597f8e0040ba3135220000b23767858c64b5c9b8 (patch)
tree8f53b497378c0736419d310a2bfe9d392b2757ac /meta/recipes-bsp
parent2127c80d0cc2a3a4d676bd3c0890454a175fba8e (diff)
downloadopenembedded-core-597f8e0040ba3135220000b23767858c64b5c9b8.tar.gz
grub-efi: Use a variable to specify built-in grub modules.
The previous behavior defines a static set of modules that are built into the grub efi executable. This works fine for a limited set of boot environments namely the standard linux/initrd. This patch conditionally assigns the same modules to a variable. This allows other meta layers to add additional modules or completely override the defaults. The use case driving this patch is the use of multiboot2 and related modules. Signed-off-by: Philip Tricca <flihp@twobit.us> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/grub/grub-efi_2.00.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi_2.00.bb b/meta/recipes-bsp/grub/grub-efi_2.00.bb
index 6944cb280e..4b43749200 100644
--- a/meta/recipes-bsp/grub/grub-efi_2.00.bb
+++ b/meta/recipes-bsp/grub/grub-efi_2.00.bb
@@ -70,12 +70,14 @@ do_install_class-native() {
install -m 755 grub-mkimage ${D}${bindir}
}
+GRUB_BUILDIN ?= "boot linux ext2 fat serial part_msdos part_gpt normal efi_gop iso9660 search"
+
do_deploy() {
# Search for the grub.cfg on the local boot media by using the
# built in cfg file provided via this recipe
grub-mkimage -c ../cfg -p /EFI/BOOT -d ./grub-core/ \
-O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
- boot linux ext2 fat serial part_msdos part_gpt normal efi_gop iso9660 search
+ ${GRUB_BUILDIN}
install -m 644 ${B}/${GRUB_IMAGE} ${DEPLOYDIR}
}