aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-08-01 18:17:59 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-08-07 11:44:34 +0100
commitacf46cb2eb03c2ed3aadd7858044ba2837a83292 (patch)
tree1bb7e24acdf4b53f05c600b716a8f77ba8f70af7 /meta/recipes-bsp
parent041342a518e1d33349eb52e11750e155a5647735 (diff)
downloadopenembedded-core-acf46cb2eb03c2ed3aadd7858044ba2837a83292.tar.gz
grub: disable floating ncurses dependency for GPLv2 version
A dependency was being added on ncurses conditionally upon whether it had been built first. Explicitly disable this dependency to stop this from happening. Note that grub 2.x does not need this same fix because there ncurses is only used when building grub-emu, which is only built when the specified target platform is "emu" which we do not use. (From OE-Core master rev: 2ca75dd0718ec37d7f131b8bcd841de6e876bd07) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/grub/grub_0.97.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_0.97.bb b/meta/recipes-bsp/grub/grub_0.97.bb
index 6971193378..38f39121d6 100644
--- a/meta/recipes-bsp/grub/grub_0.97.bb
+++ b/meta/recipes-bsp/grub/grub_0.97.bb
@@ -26,6 +26,8 @@ inherit autotools
COMPATIBLE_HOST = "i.86.*-linux"
+EXTRA_OECONF = "--without-curses"
+
do_install_append_vmware() {
mkdir -p ${D}/boot/
ln -sf ../usr/lib/grub/{$TARGET_ARCH}{$TARGET_VENDOR}/ ${D}/boot/grub