aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/uboot
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:11 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:57 +0100
commitd62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch)
treef36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/recipes-bsp/uboot
parentcaab7fc509bf27706ff3248689f6afd04225cfda (diff)
downloadopenembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-bsp/uboot')
-rw-r--r--meta/recipes-bsp/uboot/files/fix-arm920t-eabi.patch22
-rw-r--r--meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb23
-rw-r--r--meta/recipes-bsp/uboot/u-boot-mkimage_2009.08.bb25
-rw-r--r--meta/recipes-bsp/uboot/u-boot-omap3-git/beagleboard/name.patch14
-rw-r--r--meta/recipes-bsp/uboot/u-boot-omap3_git.bb20
-rw-r--r--meta/recipes-bsp/uboot/u-boot.inc38
6 files changed, 142 insertions, 0 deletions
diff --git a/meta/recipes-bsp/uboot/files/fix-arm920t-eabi.patch b/meta/recipes-bsp/uboot/files/fix-arm920t-eabi.patch
new file mode 100644
index 0000000000..69cb75891d
--- /dev/null
+++ b/meta/recipes-bsp/uboot/files/fix-arm920t-eabi.patch
@@ -0,0 +1,22 @@
+---
+ cpu/arm920t/config.mk | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- u-boot-1.3.2.orig/cpu/arm920t/config.mk
++++ u-boot-1.3.2/cpu/arm920t/config.mk
+@@ -22,13 +22,13 @@
+ #
+
+ PLATFORM_RELFLAGS += -fno-strict-aliasing -fno-common -ffixed-r8 \
+ -msoft-float
+
+-PLATFORM_CPPFLAGS += -march=armv4
++#PLATFORM_CPPFLAGS += -march=armv4
+ # =========================================================================
+ #
+ # Supply options according to compiler version
+ #
+ # =========================================================================
+-PLATFORM_CPPFLAGS +=$(call cc-option,-mapcs-32,-mabi=apcs-gnu)
++PLATFORM_CPPFLAGS +=$(call cc-option)
+ PLATFORM_RELFLAGS +=$(call cc-option,-mshort-load-bytes,$(call cc-option,-malignment-traps,))
diff --git a/meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb b/meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb
new file mode 100644
index 0000000000..fcba0d5662
--- /dev/null
+++ b/meta/recipes-bsp/uboot/u-boot-mkimage-native_1.3.2.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "U-boot bootloader mkimage tool"
+LICENSE = "GPL"
+SECTION = "bootloader"
+
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
+ file://fix-arm920t-eabi.patch;patch=1"
+
+S = "${WORKDIR}/u-boot-${PV}"
+
+inherit native
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+
+do_compile () {
+ oe_runmake smdk2410_config
+ oe_runmake tools
+}
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}
diff --git a/meta/recipes-bsp/uboot/u-boot-mkimage_2009.08.bb b/meta/recipes-bsp/uboot/u-boot-mkimage_2009.08.bb
new file mode 100644
index 0000000000..bf07198beb
--- /dev/null
+++ b/meta/recipes-bsp/uboot/u-boot-mkimage_2009.08.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "U-boot bootloader mkimage tool"
+LICENSE = "GPL"
+SECTION = "bootloader"
+
+PR = "r1"
+
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
+
+S = "${WORKDIR}/u-boot-${PV}"
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+
+BBCLASSEXTEND = "native nativesdk"
+
+do_compile () {
+ oe_runmake smdk2410_config
+ oe_runmake tools
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}
+
diff --git a/meta/recipes-bsp/uboot/u-boot-omap3-git/beagleboard/name.patch b/meta/recipes-bsp/uboot/u-boot-omap3-git/beagleboard/name.patch
new file mode 100644
index 0000000000..ac03e47774
--- /dev/null
+++ b/meta/recipes-bsp/uboot/u-boot-omap3-git/beagleboard/name.patch
@@ -0,0 +1,14 @@
+--- git/Makefile.orig 2008-07-25 16:21:22.000000000 -0700
++++ git/Makefile 2008-07-27 06:49:08.000000000 -0700
+@@ -2582,8 +2582,8 @@ SMN42_config : unconfig
+ #########################################################################
+ ## ARM CORTEX Systems
+ #########################################################################
+-omap3530beagle_config : unconfig
+- @$(MKCONFIG) $(@:_config=) arm omap3 omap3530beagle
++beagleboard_config : unconfig
++ @$(MKCONFIG) omap3530beagle arm omap3 omap3530beagle
+
+ overo_config : unconfig
+ @$(MKCONFIG) $(@:_config=) arm omap3 overo
+
diff --git a/meta/recipes-bsp/uboot/u-boot-omap3_git.bb b/meta/recipes-bsp/uboot/u-boot-omap3_git.bb
new file mode 100644
index 0000000000..480780ebfc
--- /dev/null
+++ b/meta/recipes-bsp/uboot/u-boot-omap3_git.bb
@@ -0,0 +1,20 @@
+require u-boot.inc
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/u-boot-omap3-git/${MACHINE}"
+
+SRCREV = "f40f6db278f602b55820693634a7256b0b4e4b80"
+
+PV = "2008.10-rc2+${PR}+git${SRCREV}"
+PR="r2"
+
+SRC_URI = "git://gitorious.org/u-boot-omap3/mainline.git;branch=master;protocol=git"
+
+UBOOT_MACHINE_beagleboard = "omap3_beagle_config"
+UBOOT_MACHINE_omap3evm = "omap3_evm_config"
+UBOOT_MACHINE_overo = "omap3_overo_config"
+
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+COMPATIBLE_MACHINE = "(beagleboard|omap3evm|overo)"
diff --git a/meta/recipes-bsp/uboot/u-boot.inc b/meta/recipes-bsp/uboot/u-boot.inc
new file mode 100644
index 0000000000..889f6215ed
--- /dev/null
+++ b/meta/recipes-bsp/uboot/u-boot.inc
@@ -0,0 +1,38 @@
+DESCRIPTION = "U-boot bootloader"
+HOMEPAGE = "http://u-boot.sf.net"
+SECTION = "bootloaders"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PROVIDES = "virtual/bootloader"
+
+inherit deploy
+
+PARALLEL_MAKE=""
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+
+UBOOT_MACHINE ?= "${MACHINE}_config"
+UBOOT_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.bin"
+UBOOT_SYMLINK ?= "u-boot-${MACHINE}.bin"
+
+do_compile () {
+ unset LDFLAGS
+ unset CFLAGS
+ unset CPPFLAGS
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake all
+}
+
+do_deploy () {
+ install ${S}/u-boot.bin ${DEPLOYDIR}/${UBOOT_IMAGE}
+
+ cd ${DEPLOYDIR}
+ rm -f ${UBOOT_SYMLINK}
+ ln -sf ${UBOOT_IMAGE} ${UBOOT_SYMLINK}
+}
+addtask deploy before do_build after do_compile
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 tools/mkimage ${D}${bindir}/
+}