aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-11-21 10:44:15 +0000
committerRichard Purdie <richard@openedhand.com>2006-11-21 10:44:15 +0000
commitb57a5d53ea6bdb7ce910a990f1ef584d23e6a582 (patch)
treea2c47834c6ef9a9c6291bde173a150b13cc0a8fe /meta/packages
parentf73c7d9cf6007281b87d7b2cdbcd87b79518b1c8 (diff)
downloadopenembedded-core-b57a5d53ea6bdb7ce910a990f1ef584d23e6a582.tar.gz
less: Add alternatives handling from OE.dev
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@912 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/less/less_382.bb16
1 files changed, 11 insertions, 5 deletions
diff --git a/meta/packages/less/less_382.bb b/meta/packages/less/less_382.bb
index b489722edb..f336a59ad6 100644
--- a/meta/packages/less/less_382.bb
+++ b/meta/packages/less/less_382.bb
@@ -1,16 +1,22 @@
-SECTION = "console/utils"
-DEPENDS = "ncurses"
DESCRIPTION = "Less is a program similar to more, i.e. a terminal \
based program for viewing text files and the output from other \
programs. Less offers many features beyond those that more does."
HOMEPAGE = "http://www.greenwoodsoftware.com/"
+SECTION = "console/utils"
LICENSE = "BSD"
+DEPENDS = "ncurses"
+PR = "r1"
SRC_URI = "${GNU_MIRROR}/less/less-${PV}.tar.gz \
- file://configure.patch;patch=1"
+ file://configure.patch;patch=1"
-inherit autotools
+inherit autotools update-alternatives
do_install () {
- oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
+ oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
+ mv ${D}${bindir}/less ${D}${bindir}/less.${PN}
}
+
+ALTERNATIVE_NAME = "less"
+ALTERNATIVE_PATH = "less.${PN}"
+ALTERNATIVE_PRIORITY = "100"