aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/webkit/files/configure.ac
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-04-14 09:52:55 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-04-14 09:52:55 +0000
commitd12aa66245d694ff26676294fd19b5d69cb10f50 (patch)
treecd156fb775994f5ebf57dd6c35aaa19a9d880b2a /meta/packages/webkit/files/configure.ac
parent0e55205d349e7b4b87df3a9c31dbc00caa9d235f (diff)
downloadopenembedded-core-d12aa66245d694ff26676294fd19b5d69cb10f50.tar.gz
webkit: updated to r31859 and disabled SVG fonts
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4246 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/webkit/files/configure.ac')
-rw-r--r--meta/packages/webkit/files/configure.ac56
1 files changed, 33 insertions, 23 deletions
diff --git a/meta/packages/webkit/files/configure.ac b/meta/packages/webkit/files/configure.ac
index 64f32dc689..3ab2baffb8 100644
--- a/meta/packages/webkit/files/configure.ac
+++ b/meta/packages/webkit/files/configure.ac
@@ -263,11 +263,19 @@ AC_ARG_ENABLE(cross_document_messaging,
[],[enable_cross_document_messaging="yes"])
AC_MSG_RESULT([$enable_cross_document_messaging])
+# check whether to enable HTML5 client-side session and persitent storage support
+AC_MSG_CHECKING([whether to enable HTML5 client-side session and persistent storage support])
+AC_ARG_ENABLE(dom_storage,
+ AC_HELP_STRING([--enable-dom-storage],
+ [enable HTML5 client-side session and persistent storage support [default=no]]),
+ [],[enable_dom_storage="no"])
+AC_MSG_RESULT([$enable_dom_storage])
+
# check whether to build with database support
-AC_MSG_CHECKING([whether to enable HTML5 client-side storage support])
+AC_MSG_CHECKING([whether to enable HTML5 client-side database storage support])
AC_ARG_ENABLE(database,
AC_HELP_STRING([--enable-database],
- [enable HTML5 client-side storage support [default=yes]]),
+ [enable HTML5 client-side database storage support [default=yes]]),
[],[enable_database="yes"])
AC_MSG_RESULT([$enable_database])
@@ -498,6 +506,7 @@ AM_CONDITIONAL([USE_PANGO], [test "$with_font_backend" = "pango"])
# WebKit feature conditionals
AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"])
AM_CONDITIONAL([ENABLE_CROSS_DOCUMENT_MESSAGING],[test "$enable_cross_document_messaging" = "yes"])
+AM_CONDITIONAL([ENABLE_DOM_STORAGE],[test "$enable_dom_storage" = "yes"])
AM_CONDITIONAL([ENABLE_DATABASE],[test "$enable_database" = "yes"])
AM_CONDITIONAL([ENABLE_ICONDATABASE],[test "$enable_icon_database" = "yes"])
AM_CONDITIONAL([ENABLE_XPATH],[test "$enable_xpath" = "yes"])
@@ -526,27 +535,28 @@ echo "
WebKit was configured with the following options:
Build configuration:
- Enable debugging (slow) : $enable_debug
- Code coverage support : $enable_coverage
- Unicode backend : $unicode_backend
- HTTP backend : $with_http_backend
- Font backend : $with_font_backend
- Optimized memory allocator : $enable_fast_malloc
+ Enable debugging (slow) : $enable_debug
+ Code coverage support : $enable_coverage
+ Unicode backend : $unicode_backend
+ HTTP backend : $with_http_backend
+ Font backend : $with_font_backend
+ Optimized memory allocator : $enable_fast_malloc
Features:
- HTML5 cross-document messaging : $enable_cross_document_messaging
- HTML5 client-side storage support : $enable_database
- HTML5 video element support : $enable_video
- Icon database support : $enable_icon_database
- SVG support : $enable_svg
- SVG animation support : $enable_svg_animation
- SVG filters support : $enable_svg_filters
- SVG fonts support : $enable_svg_fonts
- SVG foreign object support : $enable_svg_foreign_object
- SVG as image support : $enable_svg_as_image
- SVG use element support : $enable_svg_use_element
- XPATH support : $enable_xpath
- XSLT support : $enable_xslt
+ HTML5 cross-document messaging : $enable_cross_document_messaging
+ HTML5 client-side session and persistent storage support : $enable_dom_storage
+ HTML5 client-side database storage support : $enable_database
+ HTML5 video element support : $enable_video
+ Icon database support : $enable_icon_database
+ SVG support : $enable_svg
+ SVG animation support : $enable_svg_animation
+ SVG filters support : $enable_svg_filters
+ SVG fonts support : $enable_svg_fonts
+ SVG foreign object support : $enable_svg_foreign_object
+ SVG as image support : $enable_svg_as_image
+ SVG use element support : $enable_svg_use_element
+ XPATH support : $enable_xpath
+ XSLT support : $enable_xslt
GTK+ configuration:
- GDK target : $with_target
- Hildon UI extensions : $with_hildon
+ GDK target : $with_target
+ Hildon UI extensions : $with_hildon
"