aboutsummaryrefslogtreecommitdiffstats
path: root/meta/lib
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-28 16:49:49 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-15 10:22:26 +0100
commit49b208fc7b3d52826ba57a86ed52bc30e181ff78 (patch)
treec627188c8941f81cb60e0ca6667ca8a81e607f8f /meta/lib
parent4f528a93352c6301d57a9aaeb082d0cc313d91c3 (diff)
downloadopenembedded-core-49b208fc7b3d52826ba57a86ed52bc30e181ff78.tar.gz
make-mod-scripts/kernel-devsrc: Fix objtool issues
Kernels which use tools/objtool can now fail when building external modules due to objtool being missing, the generated files can also cause problems for kernel-devsrc. Ensure objtool is generated in make-mod-scripts by also calling "make prepare". For devsrc, delete the generated binaries since they'd be native binaries and unsuitable for the target. The oeqa kernel module tests also need to have the additional "make prepare" step added. (From OE-Core rev: 52fd2993784b4218f5df4f343e7da45d964df305) Fixes [YOCTO #12860] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> [Tweaked to add "make prepare" to module-base.bbclass instead of make-mod-scripts.bb] Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/lib')
-rw-r--r--meta/lib/oeqa/runtime/cases/kernelmodule.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/lib/oeqa/runtime/cases/kernelmodule.py b/meta/lib/oeqa/runtime/cases/kernelmodule.py
index 11ad7b7f01..de1a5aa445 100644
--- a/meta/lib/oeqa/runtime/cases/kernelmodule.py
+++ b/meta/lib/oeqa/runtime/cases/kernelmodule.py
@@ -28,7 +28,7 @@ class KernelModuleTest(OERuntimeTestCase):
@OETestDepends(['gcc.GccCompileTest.test_gcc_compile'])
def test_kernel_module(self):
cmds = [
- 'cd /usr/src/kernel && make scripts',
+ 'cd /usr/src/kernel && make scripts prepare',
'cd /tmp && make',
'cd /tmp && insmod hellomod.ko',
'lsmod | grep hellomod',