summaryrefslogtreecommitdiffstats
path: root/meta/lib/bblayers
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-06-11 09:52:06 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-15 11:09:40 +0100
commitc62f6b9643d31b465ea0e919882e411a5ed35c56 (patch)
tree90b98973cdc7921ff3546554ae8c9ff12cee1428 /meta/lib/bblayers
parent2ce3534b2011cf5516780c9fd7e00bd107619adc (diff)
downloadopenembedded-core-c62f6b9643d31b465ea0e919882e411a5ed35c56.tar.gz
bitbake-blayers/create: add version for example recipe
Add version field in recipe name for example recipe created by bitbake-layers. Fixes [YOCTO #12767] Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/lib/bblayers')
-rw-r--r--meta/lib/bblayers/create.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/lib/bblayers/create.py b/meta/lib/bblayers/create.py
index 6a41fe0504..c1923166fd 100644
--- a/meta/lib/bblayers/create.py
+++ b/meta/lib/bblayers/create.py
@@ -53,7 +53,7 @@ class CreatePlugin(LayerPlugin):
example_template = read_template('example.bb')
example = os.path.join(layerdir, 'recipes-' + args.examplerecipe, args.examplerecipe)
bb.utils.mkdirhier(example)
- with open(os.path.join(example, args.examplerecipe + '.bb'), 'w') as fd:
+ with open(os.path.join(example, args.examplerecipe + '_%s.bb') % args.version, 'w') as fd:
fd.write(example_template)
logger.plain('Add your new layer with \'bitbake-layers add-layer %s\'' % args.layerdir)
@@ -63,4 +63,5 @@ class CreatePlugin(LayerPlugin):
parser_create_layer.add_argument('layerdir', help='Layer directory to create')
parser_create_layer.add_argument('--priority', '-p', default=6, help='Layer directory to create')
parser_create_layer.add_argument('--example-recipe-name', '-e', dest='examplerecipe', default='example', help='Filename of the example recipe')
+ parser_create_layer.add_argument('--example-recipe-version', '-v', dest='version', default='0.1', help='Version number for the example recipe')