summaryrefslogtreecommitdiffstats
path: root/meta/conf
diff options
context:
space:
mode:
authorXiaofeng Yan <xiaofeng.yan@windriver.com>2012-06-26 14:15:28 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-28 16:23:18 +0100
commite65dfa26f1331b903a22353f34fb675ba0acbf30 (patch)
tree508035319f1649d2411f96cfca7fad531255398e /meta/conf
parent4800bed394ebd7fb50552a96d6a5f83d98fe790f (diff)
downloadopenembedded-core-e65dfa26f1331b903a22353f34fb675ba0acbf30.tar.gz
local.conf.sample.extended: Add filtering function to archiver.bbclass
Add the option to filter packages according to license. [YOCTO #2473] Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
Diffstat (limited to 'meta/conf')
-rw-r--r--meta/conf/local.conf.sample.extended14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta/conf/local.conf.sample.extended b/meta/conf/local.conf.sample.extended
index 1f84ac7c4f..1d19386913 100644
--- a/meta/conf/local.conf.sample.extended
+++ b/meta/conf/local.conf.sample.extended
@@ -162,5 +162,15 @@
# Whether to include WORKDIR/temp, .bb and .inc files:
# 'logs_with_scripts' include WORKDIR/temp directory and .bb and .inc files
# 'logs' only include WORKDIR/temp
-# SOURCE_ARCHIVE_LOG_WITH_SCRIPTS ?= 'logs'
-#SOURCE_ARCHIVE_LOG_WITH_SCRIPTS ?= 'logs_with_scripts'
+# ARCHIVER_MODE[log_type] = "logs logs_with_scripts"
+# There are three basic class defintions of common operations
+# that might be desired and these can be enabled by
+# uncommenting five of the following lines:
+# ARCHIVER_MODE[filter] ?= "yes no"
+# Filter packages according to license
+#ARCHIVER_MODE ?= "original"
+#ARCHIVER_MODE[type] ?= "tar"
+#ARCHIVER_MODE[log_type] ?= "logs_with_scripts"
+#ARCHIVER_MODE[filter] ?= "no"
+#ARCHIVER_CLASS = "${@'archive-${ARCHIVER_MODE}-source' if ARCHIVER_MODE != 'none' else ''}"
+#INHERIT += "${ARCHIVER_CLASS}"