aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-28 16:49:49 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-15 10:22:26 +0100
commit49b208fc7b3d52826ba57a86ed52bc30e181ff78 (patch)
treec627188c8941f81cb60e0ca6667ca8a81e607f8f /meta/classes
parent4f528a93352c6301d57a9aaeb082d0cc313d91c3 (diff)
downloadopenembedded-core-49b208fc7b3d52826ba57a86ed52bc30e181ff78.tar.gz
make-mod-scripts/kernel-devsrc: Fix objtool issues
Kernels which use tools/objtool can now fail when building external modules due to objtool being missing, the generated files can also cause problems for kernel-devsrc. Ensure objtool is generated in make-mod-scripts by also calling "make prepare". For devsrc, delete the generated binaries since they'd be native binaries and unsuitable for the target. The oeqa kernel module tests also need to have the additional "make prepare" step added. (From OE-Core rev: 52fd2993784b4218f5df4f343e7da45d964df305) Fixes [YOCTO #12860] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> [Tweaked to add "make prepare" to module-base.bbclass instead of make-mod-scripts.bb] Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/classes')
-rw-r--r--meta/classes/module-base.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/classes/module-base.bbclass b/meta/classes/module-base.bbclass
index 6fe77c01b7..64729770c7 100644
--- a/meta/classes/module-base.bbclass
+++ b/meta/classes/module-base.bbclass
@@ -23,5 +23,5 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
do_make_scripts() {
unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
make CC="${KERNEL_CC}" LD="${KERNEL_LD}" AR="${KERNEL_AR}" \
- -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} scripts
+ -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} scripts prepare
}