aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/sign_package_feed.bbclass
diff options
context:
space:
mode:
authorRandy Witt <randy.e.witt@linux.intel.com>2016-02-19 08:45:25 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-26 17:16:01 +0000
commit1e38068ac38dfd067655dfd41464e28439179306 (patch)
tree366f29e80330afdf9d95e27886dd48774ea381c4 /meta/classes/sign_package_feed.bbclass
parent50743301bd8c0c4817d039d08c9567d15243a74d (diff)
downloadopenembedded-core-1e38068ac38dfd067655dfd41464e28439179306.tar.gz
signing-keys: Make signing keys the only publisher of keys
Previously the keys were put into the os-release package. The package indexing code was also deploying the keys rather than only using the keys. This change makes signing-keys.bb the only publisher of the keys and also uses standard tasks that already have sstate. Signed-off-by: Randy Witt <randy.e.witt@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/sign_package_feed.bbclass')
-rw-r--r--meta/classes/sign_package_feed.bbclass9
1 files changed, 2 insertions, 7 deletions
diff --git a/meta/classes/sign_package_feed.bbclass b/meta/classes/sign_package_feed.bbclass
index 63ca02fd9d..e1ec82e2ff 100644
--- a/meta/classes/sign_package_feed.bbclass
+++ b/meta/classes/sign_package_feed.bbclass
@@ -27,12 +27,7 @@ python () {
for var in ('PACKAGE_FEED_GPG_NAME', 'PACKAGE_FEED_GPG_PASSPHRASE_FILE'):
if not d.getVar(var, True):
raise_sanity_error("You need to define %s in the config" % var, d)
-
- # Set expected location of the public key
- d.setVar('PACKAGE_FEED_GPG_PUBKEY',
- os.path.join(d.getVar('STAGING_ETCDIR_NATIVE', False),
- 'PACKAGE-FEED-GPG-PUBKEY'))
}
-do_package_index[depends] += "signing-keys:do_export_public_keys"
-do_rootfs[depends] += "signing-keys:do_export_public_keys"
+do_package_index[depends] += "signing-keys:do_deploy"
+do_rootfs[depends] += "signing-keys:do_populate_sysroot"