summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2015-09-28 10:12:57 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-10-01 07:40:22 +0100
commitdc26472661bdc0ed4248d7ab462a296f3c86c421 (patch)
treec13258120b5fac4e6a91bb8905510be3ff4f401d /meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
parent8b97d9320b989023c62db8246f5d8d2126c3723e (diff)
downloadopenembedded-core-dc26472661bdc0ed4248d7ab462a296f3c86c421.tar.gz
linux-yocto-custom: Update for newer kernel
Update the NAME version tweak example patch for the newer kernel. This moves the example to the 4.2 stable kernel and appends -custom to the VERSION string. Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb')
-rw-r--r--meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb15
1 files changed, 7 insertions, 8 deletions
diff --git a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
index cce44d9995..6194d4f8da 100644
--- a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
+++ b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
@@ -43,9 +43,9 @@
#
# example configuration addition:
# SRC_URI += "file://smp.cfg"
-# example patch addition (for kernel v3.4 only):
-# SRC_URI += "file://0001-linux-version-tweak.patch
-# example feature addition (for kernel v3.4 only):
+# example patch addition (for kernel v4.x only):
+# SRC_URI += "file://0001-linux-version-tweak.patch"
+# example feature addition (for kernel v4.x only):
# SRC_URI += "file://feature.scc"
#
@@ -56,15 +56,14 @@ require recipes-kernel/linux/linux-yocto.inc
# tree if you do not want to build from Linus' tree.
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1;name=machine"
-LINUX_VERSION ?= "3.4"
-LINUX_VERSION_EXTENSION ?= "-custom"
+LINUX_VERSION ?= "4.2"
+LINUX_VERSION_EXTENSION_append = "-custom"
# Modify SRCREV to a different commit hash in a copy of this recipe to
# build a different release of the Linux kernel.
-# tag: v3.4 76e10d158efb6d4516018846f60c2ab5501900bc
-SRCREV_machine="76e10d158efb6d4516018846f60c2ab5501900bc"
+# tag: v4.2 64291f7db5bd8150a74ad2036f1037e6a0428df2
+SRCREV_machine="64291f7db5bd8150a74ad2036f1037e6a0428df2"
-PR = "r1"
PV = "${LINUX_VERSION}+git${SRCPV}"
# Override COMPATIBLE_MACHINE to include your machine in a copy of this recipe