summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2021-03-31 18:46:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-04-05 15:28:25 +0100
commitf8aa80a8fc777464f20e864b53af0582487d0387 (patch)
treee7bc8902d04c71bde3a459c7ff22b6cb18472c7d
parentfd2b8986aef11609123da917aaf6bcbe41f63112 (diff)
downloadopenembedded-core-f8aa80a8fc777464f20e864b53af0582487d0387.tar.gz
apt: Fix do_compile error when enable ccache
When apt was upgraded, the '-DCMAKE_DISABLE_FIND_PACKAGE_Zstd=True' was dropped. However, it was there to fix do_compile error when ccache is enabled. See details in the following commit. """ commit 0aa7d612b8b7e5f14b4ed38f2a32b3f7eefca31c Author: Robert Yang <liezhi.yang@windriver.com> Date: Tue Jan 19 01:23:45 2021 -0800 apt: Fix do_compile error when enable ccache Fixed: apt-pkg/libapt-pkg.so.5.0.2: undefined reference to `ZSTD_endStream' collect2: error: ld returned 1 exit status This is because ccache-native depends on zstd-native which makes apt wronly find it. Disable zstd for apt to fix the problem. """ Now we are meeting do_compile failure again when enabling ccache, so add it back to solve the problem. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/apt/apt_2.2.2.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/apt/apt_2.2.2.bb b/meta/recipes-devtools/apt/apt_2.2.2.bb
index d1aa5de8df..7d1bce558d 100644
--- a/meta/recipes-devtools/apt/apt_2.2.2.bb
+++ b/meta/recipes-devtools/apt/apt_2.2.2.bb
@@ -44,6 +44,7 @@ DEPENDS += "db gnutls lz4 zlib bzip2 xz libgcrypt xxhash"
EXTRA_OECMAKE_append = " -DCURRENT_VENDOR=debian -DWITH_DOC=False \
-DDPKG_DATADIR=${datadir}/dpkg \
-DTRIEHASH_EXECUTABLE=${WORKDIR}/triehash \
+ -DCMAKE_DISABLE_FIND_PACKAGE_ZSTD=True \
-DWITH_TESTS=False \
"