summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-07-10 03:42:33 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-17 10:47:37 +0100
commitf3ea68cdd2559d84d5b2cd95323d186fff14c7b7 (patch)
tree8beeda323c44a5d7dee1bb6d98d888b8e3c4aac3
parentc654e26007b4b014bc614fde15b7a8d9cf52d849 (diff)
downloadopenembedded-core-f3ea68cdd2559d84d5b2cd95323d186fff14c7b7.tar.gz
webgit-gtk: fix build with automake 1.12.1
Added a new patch: webgit-gtk_fix_build_with_automake_1.12.patch More comments in the patch header. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-sato/webkit/files/webgit-gtk_fix_build_with_automake_1.12.patch62
-rw-r--r--meta/recipes-sato/webkit/webkit-gtk_svn.bb1
2 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/files/webgit-gtk_fix_build_with_automake_1.12.patch b/meta/recipes-sato/webkit/files/webgit-gtk_fix_build_with_automake_1.12.patch
new file mode 100644
index 0000000000..ad7c55f264
--- /dev/null
+++ b/meta/recipes-sato/webkit/files/webgit-gtk_fix_build_with_automake_1.12.patch
@@ -0,0 +1,62 @@
+Upstream-Status: Pending
+
+automake 1.12 has deprecated use of mkdir_p, and it recommends
+use of MKDIR_P instead. Changed the code to avoid these kind
+of warning-errors.
+
+./.deps/DerivedSources
+make[1]: ./.deps/DerivedSources: Command not found
+make[1]: *** [all-local] Error 127
+
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+2012/07/10
+
+Index: webkit-gtk-1.7.2+svnr101488-r6/GNUmakefile.am
+===================================================================
+--- webkit-gtk-1.7.2+svnr101488-r6.orig/GNUmakefile.am
++++ webkit-gtk-1.7.2+svnr101488-r6/GNUmakefile.am
+@@ -255,7 +255,7 @@ MAINTAINERCLEANFILES += \
+ # Older automake versions (1.7) place Plo files in a different place so we need
+ # to create the output directory manually.
+ all-local: stamp-po
+- $(mkdir_p) $(top_builddir)/$(DEPDIR)/DerivedSources
++ $(MKDIR_P) $(top_builddir)/$(DEPDIR)/DerivedSources
+
+ # remove built sources and program directories
+ clean-local:
+Index: webkit-gtk-1.7.2+svnr101488-r6/Source/WebKit/gtk/po/GNUmakefile.am
+===================================================================
+--- webkit-gtk-1.7.2+svnr101488-r6.orig/Source/WebKit/gtk/po/GNUmakefile.am
++++ webkit-gtk-1.7.2+svnr101488-r6/Source/WebKit/gtk/po/GNUmakefile.am
+@@ -132,13 +132,13 @@ DISTCLEANFILES += \
+ $(top_builddir)/Source/WebKit/gtk/po/$(DOMAIN).pot
+
+ po-install-data-local: all
+- $(mkdir_p) $(DESTDIR)$(datadir)
++ $(MKDIR_P) $(DESTDIR)$(datadir)
+ @catalogs='$(MOFILES)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+ lang=`echo $$cat | sed -e 's/\.mo$$//'`; \
+ dir=$(localedir)/$$lang/LC_MESSAGES; \
+- $(mkdir_p) $(DESTDIR)$$dir; \
++ $(MKDIR_P) $(DESTDIR)$$dir; \
+ if test -r Source/WebKit/gtk/po/$$cat; then realcat=Source/WebKit/gtk/po/$$cat; else realcat=$(srcdir)/$$cat; fi; \
+ $(INSTALL_DATA) $$realcat $(DESTDIR)$$dir/$(DOMAIN).mo; \
+ echo "installing $$realcat as $(DESTDIR)$$dir/$(DOMAIN).mo"; \
+@@ -173,13 +173,13 @@ po-install-data-local: all
+ done
+
+ po-installdirs-data-local:
+- $(mkdir_p) $(DESTDIR)$(datadir)
++ $(MKDIR_P) $(DESTDIR)$(datadir)
+ @catalogs='$(MOFILES)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+ lang=`echo $$cat | sed -e 's/\.gmo$$//'`; \
+ dir=$(localedir)/$$lang/LC_MESSAGES; \
+- $(mkdir_p) $(DESTDIR)$$dir; \
++ $(MKDIR_P) $(DESTDIR)$$dir; \
+ for lc in '' $(EXTRA_LOCALE_CATEGORIES); do \
+ if test -n "$$lc"; then \
+ if (cd $(DESTDIR)$(localedir)/$$lang && LC_ALL=C ls -l -d $$lc 2>/dev/null) | grep ' -> ' >/dev/null; then \
diff --git a/meta/recipes-sato/webkit/webkit-gtk_svn.bb b/meta/recipes-sato/webkit/webkit-gtk_svn.bb
index 6a6839d28f..b455759f36 100644
--- a/meta/recipes-sato/webkit/webkit-gtk_svn.bb
+++ b/meta/recipes-sato/webkit/webkit-gtk_svn.bb
@@ -33,6 +33,7 @@ SRC_URI = "\
file://gtk-doc.make \
file://nodolt.patch \
file://function-scope.patch \
+ file://webgit-gtk_fix_build_with_automake_1.12.patch \
"
S = "${WORKDIR}/"