summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2018-07-05 22:07:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-06 22:54:56 +0100
commitc1f18efda0280644b4a4ce6f2988fb7ada71faf6 (patch)
tree806159d7c2f7a3c8109f5e720e7425ba08c5b3b6
parent5646516dafbd2536e30d5f01c9e30fd34fcc7da1 (diff)
downloadopenembedded-core-c1f18efda0280644b4a4ce6f2988fb7ada71faf6.tar.gz
ca-certificates: avoid using += with an over-ride
Using += with an over-ride can be a source of confusion so try to avoid the construct in core recipes. In this case, the commit which added the over-ride seems to have been buggy - the commit message mentions "add to SYSROOT_DIRS" rather than a correct description of what the change actually did, ie "over-ride SYSROOT_DIRS": http://git.openembedded.org/openembedded-core/commit/?id=355e49e19abb3e729c82a6de46ada8da8a257f58 The commit also appears to have been unnecessary as ${sysconfdir} is appended to SYSROOT_DIRS for -native recipes by default from within staging.bbclass. To workaround the bug introduced by the first commit, a subsequent commit later added ${datadir}/ca-certificates to the over-ride value (which would not normally be necessary as ${datadir} is included in the default value of SYSROOT_DIRS - ie the value which was lost due to being over-ridden): http://git.openembedded.org/openembedded-core/commit/?id=09bb7718d74573be9a5db4d0737fb14126f6489c Therefore the fix seem to be to remove the SYSROOT_DIRS over-ride entirely - the default value of SYSROOT_DIRS set by staging.bbclass includes both ${datadir} and ${sysconfdir} when building for -native. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/ca-certificates/ca-certificates_20170717.bb1
1 files changed, 0 insertions, 1 deletions
diff --git a/meta/recipes-support/ca-certificates/ca-certificates_20170717.bb b/meta/recipes-support/ca-certificates/ca-certificates_20170717.bb
index 350294858b..24d3a6e4d3 100644
--- a/meta/recipes-support/ca-certificates/ca-certificates_20170717.bb
+++ b/meta/recipes-support/ca-certificates/ca-certificates_20170717.bb
@@ -26,7 +26,6 @@ SRC_URI = "git://salsa.debian.org/debian/ca-certificates.git;protocol=https \
"
S = "${WORKDIR}/git"
-SYSROOT_DIRS_class-native += "${sysconfdir} ${datadir}/ca-certificates"
inherit allarch