summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-04-06 17:36:41 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-09 19:48:03 +0100
commitbdd9bd8beaf49133cd62b27255897cdbd2b42b49 (patch)
treef073be1ff3e2c90dbac6ed76a71cf5bb33379d61
parent7d1599cf6a55d3624d2b90c1f55e14c4df73e570 (diff)
downloadopenembedded-core-bdd9bd8beaf49133cd62b27255897cdbd2b42b49.tar.gz
libdaemon: Explicitly include unisttd.h instead of sys/unistd.h
Fixes build errors on musl Change-Id: Ia00bdc9c0578c8d5e1249c9d433079d795e83cb2 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/libdaemon/libdaemon/fix-includes.patch20
-rw-r--r--meta/recipes-support/libdaemon/libdaemon_0.14.bb4
2 files changed, 23 insertions, 1 deletions
diff --git a/meta/recipes-support/libdaemon/libdaemon/fix-includes.patch b/meta/recipes-support/libdaemon/libdaemon/fix-includes.patch
new file mode 100644
index 0000000000..1027ae8e6c
--- /dev/null
+++ b/meta/recipes-support/libdaemon/libdaemon/fix-includes.patch
@@ -0,0 +1,20 @@
+musl complains
+fatal error: sys/unistd.h: No such file or directory
+and rightly so
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Pending
+
+--- libdaemon-0.14.orig/examples/testd.c
++++ libdaemon-0.14/examples/testd.c
+@@ -21,9 +21,9 @@
+ #include <signal.h>
+ #include <errno.h>
+ #include <string.h>
++#include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/time.h>
+-#include <sys/unistd.h>
+ #include <sys/select.h>
+
+ #include <libdaemon/dfork.h>
diff --git a/meta/recipes-support/libdaemon/libdaemon_0.14.bb b/meta/recipes-support/libdaemon/libdaemon_0.14.bb
index e928781a4d..070ee1890e 100644
--- a/meta/recipes-support/libdaemon/libdaemon_0.14.bb
+++ b/meta/recipes-support/libdaemon/libdaemon_0.14.bb
@@ -6,7 +6,9 @@ LICENSE = "LGPLv2.1+"
LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
file://libdaemon/daemon.h;beginline=9;endline=21;md5=bd9fbe57cd96d1a5848a8ba12d9a6bf4"
-SRC_URI = "http://0pointer.de/lennart/projects/libdaemon/libdaemon-${PV}.tar.gz"
+SRC_URI = "http://0pointer.de/lennart/projects/libdaemon/libdaemon-${PV}.tar.gz \
+ file://fix-includes.patch \
+ "
SRC_URI[md5sum] = "509dc27107c21bcd9fbf2f95f5669563"
SRC_URI[sha256sum] = "fd23eb5f6f986dcc7e708307355ba3289abe03cc381fc47a80bca4a50aa6b834"