summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-11-16 09:24:31 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:47:09 +0000
commitb91469ac21825a86eb7a71f1e91206719061bcaa (patch)
tree22c8a8f841630bb29f374a8ca60a2a32ba305efe
parent74408c19fba89de54c093fccf65b3a072d6a197b (diff)
downloadopenembedded-core-b91469ac21825a86eb7a71f1e91206719061bcaa.tar.gz
linux-yocto/4.8: fix cryptodev compilation error
It was reported that compilation was broken for the in tree variant of cryptodev. This commit integrates two patches that fix the issue: efbdfa1ed95f cryptodev: stomp dynamic version numbering for in tree builds 32f54070205f cryptodev: fix compile error when enable CONFIG_CRYPTODEV Signed-off-by: Liwei Song <liwei.song@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.8.bb18
3 files changed, 13 insertions, 13 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb
index 26b309d8b8..e70523a307 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb
@@ -11,8 +11,8 @@ python () {
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "b99b6fac437104e206d30540a5cb12103049af1e"
-SRCREV_meta ?= "87e5fc8b7cb387f197cdd098cdde4e96e9e8ed0d"
+SRCREV_machine ?= "ab1036645c083ebb30fee3eab591b0c3b5040ebb"
+SRCREV_meta ?= "d7a58814eee97e7bf410e418ad087a1f7bb05ab9"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.8.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.8;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb
index 63dd11baa1..ab7a47ef7f 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb
@@ -9,8 +9,8 @@ LINUX_VERSION ?= "4.8.6"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "9d5f74f941c3ca234f58ff8e539f5ca64458c0a7"
-SRCREV_meta ?= "87e5fc8b7cb387f197cdd098cdde4e96e9e8ed0d"
+SRCREV_machine ?= "efbdfa1ed95f7f0b4243351ffdb2d30e58308aeb"
+SRCREV_meta ?= "d7a58814eee97e7bf410e418ad087a1f7bb05ab9"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.8.bb b/meta/recipes-kernel/linux/linux-yocto_4.8.bb
index 03691982b1..a92e9cff87 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.8.bb
@@ -11,15 +11,15 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "94d3e8675e2fcb09f29814a33ccf79df06149104"
-SRCREV_machine_qemuarm64 ?= "9d5f74f941c3ca234f58ff8e539f5ca64458c0a7"
-SRCREV_machine_qemumips ?= "046ff6344eee25dcc0eea1214e0ad8771ddfabfb"
-SRCREV_machine_qemuppc ?= "9d5f74f941c3ca234f58ff8e539f5ca64458c0a7"
-SRCREV_machine_qemux86 ?= "9d5f74f941c3ca234f58ff8e539f5ca64458c0a7"
-SRCREV_machine_qemux86-64 ?= "9d5f74f941c3ca234f58ff8e539f5ca64458c0a7"
-SRCREV_machine_qemumips64 ?= "edcb167f91abc071cc98cbd762418ff7ab9d839b"
-SRCREV_machine ?= "9d5f74f941c3ca234f58ff8e539f5ca64458c0a7"
-SRCREV_meta ?= "87e5fc8b7cb387f197cdd098cdde4e96e9e8ed0d"
+SRCREV_machine_qemuarm ?= "ae6282e4c25529f2649f8fa31d45c1b5bf5daf42"
+SRCREV_machine_qemuarm64 ?= "efbdfa1ed95f7f0b4243351ffdb2d30e58308aeb"
+SRCREV_machine_qemumips ?= "87fd523e80256e404710624b5c45d76da369f9b5"
+SRCREV_machine_qemuppc ?= "efbdfa1ed95f7f0b4243351ffdb2d30e58308aeb"
+SRCREV_machine_qemux86 ?= "efbdfa1ed95f7f0b4243351ffdb2d30e58308aeb"
+SRCREV_machine_qemux86-64 ?= "efbdfa1ed95f7f0b4243351ffdb2d30e58308aeb"
+SRCREV_machine_qemumips64 ?= "13669dd21e6c8e0cfccc1c6ccc3f83e272f0f6d1"
+SRCREV_machine ?= "efbdfa1ed95f7f0b4243351ffdb2d30e58308aeb"
+SRCREV_meta ?= "d7a58814eee97e7bf410e418ad087a1f7bb05ab9"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.8.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.8;destsuffix=${KMETA}"