summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan McGregor <dan.mcgregor@usask.ca>2015-02-04 10:09:13 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-07 18:52:44 +0000
commitb2cee9b9f08dff41e46e227b1ffa5e46e98faa89 (patch)
tree2c1a0bbf3b00eeb4145e8bc71d8741e83f2e4f4d
parentb4f2f39ce0f4690ed51d14d1034b9f5e21c0f5a0 (diff)
downloadopenembedded-core-b2cee9b9f08dff41e46e227b1ffa5e46e98faa89.tar.gz
openssh: Fix non-deterministic build behaviour
If maillock.h is found, a dependency on liblockfile will be created. liblockfile is in meta-oe, so we don't want that in an oe-core recipe. Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-connectivity/openssh/openssh_6.7p1.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh_6.7p1.bb b/meta/recipes-connectivity/openssh/openssh_6.7p1.bb
index dcbc181aa9..a2726291fe 100644
--- a/meta/recipes-connectivity/openssh/openssh_6.7p1.bb
+++ b/meta/recipes-connectivity/openssh/openssh_6.7p1.bb
@@ -62,6 +62,9 @@ CACHED_CONFIGUREVARS += "ac_cv_header_bsd_libutil_h=no ac_cv_header_libutil_h=no
# passwd path is hardcoded in sshd
CACHED_CONFIGUREVARS += "ac_cv_path_PATH_PASSWD_PROG=${bindir}/passwd"
+# We don't want to depend on libblockfile
+CACHED_CONFIGUREVARS += "ac_cv_header_maillock_h=no"
+
# This is a workaround for uclibc because including stdio.h
# pulls in pthreads.h and causes conflicts in function prototypes.
# This results in compilation failure, so unless this is fixed,