summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCheuk Wing Leung <cwleung@kth.se>2018-10-11 16:15:54 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-13 16:03:44 +0100
commitb0cbd9efc30289bb4838dcaa43beba2c0c372ab2 (patch)
treedc6a7390f5a60c0d0ebaf809475922acb323c09b
parent94cea72a23a374eb616d5642977b45172537beac (diff)
downloadopenembedded-core-b0cbd9efc30289bb4838dcaa43beba2c0c372ab2.tar.gz
python3: set PYTHONHOME for nativesdk
commit c5629268b0f8ae0a425c98337d13e8dc83107e13: [ python: set PYTHONHOME for nativesdk This ensures that the nativesdk python functions correctly without needing to set PYTHONHOME in the sdk environment setup script. ] it's also needed for python3. Signed-off-by: Cheuk Wing Leung <cwleung@kth.se> Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3_3.5.6.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.6.bb b/meta/recipes-devtools/python/python3_3.5.6.bb
index e179658134..c481aadb36 100644
--- a/meta/recipes-devtools/python/python3_3.5.6.bb
+++ b/meta/recipes-devtools/python/python3_3.5.6.bb
@@ -179,7 +179,7 @@ do_install() {
}
do_install_append_class-nativesdk () {
- create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1'
+ create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} PYTHONHOME='${prefix}' TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1'
}
SSTATE_SCAN_FILES += "Makefile"