summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-01-13 08:03:28 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-14 11:21:58 +0000
commitb020a7139a6fd9efd052a3dc3c02a41f621ae952 (patch)
tree0b37e60e8c8f2e7c9b2e8b37ad319c521bd9d01a
parentde199097b5c883ee348c9d631601d5d30c28e342 (diff)
downloadopenembedded-core-b020a7139a6fd9efd052a3dc3c02a41f621ae952.tar.gz
python3-pbr: Move src uri checksums out of .inc file
python2 version of pbr is in meta-python and uses the same inc file but is not updated synchronously, which ends up breaking it, either we move py2 version into OE-core as well and then ensure that both recipes are updated atomically, or we move the checksums into recipe files Fixes errors like http://errors.yoctoproject.org/Errors/Details/216253/ Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python-pbr.inc3
-rw-r--r--meta/recipes-devtools/python/python3-pbr_5.1.1.bb3
2 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python-pbr.inc b/meta/recipes-devtools/python/python-pbr.inc
index bfe3030b07..0e64501c32 100644
--- a/meta/recipes-devtools/python/python-pbr.inc
+++ b/meta/recipes-devtools/python/python-pbr.inc
@@ -5,9 +5,6 @@ SECTION = "devel/python"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
-SRC_URI[md5sum] = "dbc94417a8ff0432d6244501a7f1bd49"
-SRC_URI[sha256sum] = "f59d71442f9ece3dffc17bc36575768e1ee9967756e6b6535f0ee1f0054c3d68"
-
inherit pypi
RDEPENDS_${PN} += "${PYTHON_PN}-pip"
diff --git a/meta/recipes-devtools/python/python3-pbr_5.1.1.bb b/meta/recipes-devtools/python/python3-pbr_5.1.1.bb
index 97e7361b16..95d3d2bd4f 100644
--- a/meta/recipes-devtools/python/python3-pbr_5.1.1.bb
+++ b/meta/recipes-devtools/python/python3-pbr_5.1.1.bb
@@ -1,2 +1,5 @@
inherit setuptools3
require python-pbr.inc
+SRC_URI[md5sum] = "dbc94417a8ff0432d6244501a7f1bd49"
+SRC_URI[sha256sum] = "f59d71442f9ece3dffc17bc36575768e1ee9967756e6b6535f0ee1f0054c3d68"
+