summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-13 09:08:09 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-14 11:41:14 +0100
commitae4729ed6c5e5443c42f8825dd85873f06a3570e (patch)
tree1e5f65d7ce338ed790bdfa2e3f25b9c84298aae8
parent1ae7e1cc4a5c7a217dee937c330539e5c8ac794d (diff)
downloadopenembedded-core-ae4729ed6c5e5443c42f8825dd85873f06a3570e.tar.gz
glibc: Fix x32 make race
On x32 builds, sysd-syscalls appears malformed since the make-target-directory appears on the wrong line. This causes races during the build process where you can see failures like: Assembler messages: Fatal error: can't create [...]glibc/2.21-r0/build-x86_64-poky-linux-gnux32/time/gettimeofday.os: No such file or directory Assembler messages: Fatal error: can't create [...]glibc/2.21-r0/build-x86_64-poky-linux-gnux32/time/time.os: No such file or directory The issue is that the carriage return is being escaped when it should not be. The change to sysd-syscalls with this change: before: """ $(foreach p,$(sysd-rules-targets),$(objpfx)$(patsubst %,$p,time).os): \ $(..)sysdeps/unix/make-syscalls.sh $(make-target-directory) (echo '#include <dl-vdso.h>'; """ after: """ $(foreach p,$(sysd-rules-targets),$(objpfx)$(patsubst %,$p,time).os): \ $(..)sysdeps/unix/make-syscalls.sh $(make-target-directory) (echo '#include <dl-vdso.h>'; """ which ensures the target directory is correctly created. Only x32 uses the vdso code which contains the bug which is why the error only really appears on x32. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/glibc/glibc/makesyscall.patch51
-rw-r--r--meta/recipes-core/glibc/glibc_2.21.bb1
2 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc/makesyscall.patch b/meta/recipes-core/glibc/glibc/makesyscall.patch
new file mode 100644
index 0000000000..9ab597f604
--- /dev/null
+++ b/meta/recipes-core/glibc/glibc/makesyscall.patch
@@ -0,0 +1,51 @@
+On x32 builds, sysd-syscalls appears malformed since the make-target-directory
+appears on the wrong line. This causes races during the build process where you can
+see failures like:
+
+Assembler messages:
+Fatal error: can't create [...]glibc/2.21-r0/build-x86_64-poky-linux-gnux32/time/gettimeofday.os: No such file or directory
+Assembler messages:
+Fatal error: can't create [...]glibc/2.21-r0/build-x86_64-poky-linux-gnux32/time/time.os: No such file or directory
+
+The isue is that the carridge return is being escaped when it should
+not be. The change to sysd-syscalls with this change:
+
+before:
+
+"""
+$(foreach p,$(sysd-rules-targets),$(objpfx)$(patsubst %,$p,time).os): \
+ $(..)sysdeps/unix/make-syscalls.sh $(make-target-directory)
+ (echo '#include <dl-vdso.h>';
+"""
+
+after:
+
+"""
+$(foreach p,$(sysd-rules-targets),$(objpfx)$(patsubst %,$p,time).os): \
+ $(..)sysdeps/unix/make-syscalls.sh
+ $(make-target-directory)
+ (echo '#include <dl-vdso.h>';
+"""
+
+which ensures the target directory is correctly created. Only x32 uses the vdso
+code which contains the bug which is why the error only really appears on x32.
+
+Upstream Bug: https://sourceware.org/bugzilla/show_bug.cgi?id=18409
+Upstream Fix: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=d9efd775ba51916b58b899d8b1c8501105a830de
+
+Upstream-Status: Backport
+RP 2015/5/13
+
+Index: git/sysdeps/unix/make-syscalls.sh
+===================================================================
+--- git.orig/sysdeps/unix/make-syscalls.sh
++++ git/sysdeps/unix/make-syscalls.sh
+@@ -278,7 +278,7 @@ while read file srcfile caller syscall a
+ vdso_symver=`echo "$vdso_symver" | sed 's/\./_/g'`
+ echo "\
+ \$(foreach p,\$(sysd-rules-targets),\$(objpfx)\$(patsubst %,\$p,$file).os): \\
+- \$(..)sysdeps/unix/make-syscalls.sh\
++ \$(..)sysdeps/unix/make-syscalls.sh
+ \$(make-target-directory)
+ (echo '#include <dl-vdso.h>'; \\
+ echo 'extern void *${strong}_ifunc (void) __asm (\"${strong}\");'; \\
diff --git a/meta/recipes-core/glibc/glibc_2.21.bb b/meta/recipes-core/glibc/glibc_2.21.bb
index 58a9601034..ac8e8f8200 100644
--- a/meta/recipes-core/glibc/glibc_2.21.bb
+++ b/meta/recipes-core/glibc/glibc_2.21.bb
@@ -26,6 +26,7 @@ SRC_URI = "git://sourceware.org/git/glibc.git;branch=${BRANCH} \
file://0001-When-disabling-SSE-also-make-sure-that-fpmath-is-not.patch \
file://0001-yes-within-the-path-sets-wrong-config-variables.patch \
file://elf-Makefile-fix-a-typo.patch \
+ file://makesyscall.patch \
${EGLIBCPATCHES} \
"
EGLIBCPATCHES = "\