summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-08 20:18:00 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-09 09:16:04 -0800
commita3221aa92fa4423da3b70b8d673cf68be08ad922 (patch)
tree431972d203a5f546a59a9f4344a2512bfa147f1b
parent10ae328607511e7092a9e6f75c8f382b7e3dd27b (diff)
downloadopenembedded-core-a3221aa92fa4423da3b70b8d673cf68be08ad922.tar.gz
irda-utils: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-connectivity/irda-utils/irda-utils-0.9.18/ldflags.patch64
1 files changed, 38 insertions, 26 deletions
diff --git a/meta/recipes-connectivity/irda-utils/irda-utils-0.9.18/ldflags.patch b/meta/recipes-connectivity/irda-utils/irda-utils-0.9.18/ldflags.patch
index e95fe35f8f..b246de8f5f 100644
--- a/meta/recipes-connectivity/irda-utils/irda-utils-0.9.18/ldflags.patch
+++ b/meta/recipes-connectivity/irda-utils/irda-utils-0.9.18/ldflags.patch
@@ -3,72 +3,84 @@ Obey LDFLAGS
Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Upstream-Status: Pending
+Index: irda-utils-0.9.18/findchip/Makefile
+===================================================================
--- irda-utils-0.9.18.orig/findchip/Makefile
+++ irda-utils-0.9.18/findchip/Makefile
@@ -65,5 +65,5 @@ install: findchip
-
- gfindchip: gfindchip.c
- $(prn_cc)
+
+ gfindchip: gfindchip.c
+ $(prn_cc)
- $(ECMD))$(CC) $(CFLAGS) `gtk-config --cflags` $< -o $@ `gtk-config --libs`
+ $(ECMD)$(CC) $(CFLAGS) $(LDFLAGS) `gtk-config --cflags` $< -o $@ `gtk-config --libs`
-
+
+Index: irda-utils-0.9.18/irattach/Makefile
+===================================================================
--- irda-utils-0.9.18.orig/irattach/Makefile
+++ irda-utils-0.9.18/irattach/Makefile
@@ -49,13 +49,13 @@ all: $(TARGETS)
-
+
irattach: irattach.o util.o
- $(prn_cc_o)
+ $(prn_cc_o)
- $(ECMD)$(CC) $(CFLAGS) irattach.o util.o -o $@
+ $(ECMD)$(CC) $(CFLAGS) $(LDFLAGS) irattach.o util.o -o $@
-
-
-
+
+
+
dongle_attach: dongle_attach.o
- $(prn_cc_o)
+ $(prn_cc_o)
- $(ECMD)$(CC) $(CFLAGS) dongle_attach.o -o $@
+ $(ECMD)$(CC) $(CFLAGS) $(LDFLAGS) dongle_attach.o -o $@
-
-
+
+
install: $(TARGETS)
+Index: irda-utils-0.9.18/irdadump/Makefile
+===================================================================
--- irda-utils-0.9.18.orig/irdadump/Makefile
+++ irda-utils-0.9.18/irdadump/Makefile
@@ -40,7 +40,7 @@ lib_irdadump.a: $(LIBIRDADUMP_OBJS)
-
+
irdadump: $(IRDADUMP_OBJS) $(LIBIRDADUMP_TARGET)
- $(prn_cc_o)
+ $(prn_cc_o)
- $(ECMD)$(CC) $(CFLAGS) `pkg-config --libs glib-2.0` -o $(IRDADUMP_TARGET) $< $(LIBIRDADUMP_TARGET)
+ $(ECMD)$(CC) $(CFLAGS) $(LDFLAGS) `pkg-config --libs glib-2.0` -o $(IRDADUMP_TARGET) $< $(LIBIRDADUMP_TARGET)
-
-
+
+
.c.o:
+Index: irda-utils-0.9.18/irdaping/Makefile
+===================================================================
--- irda-utils-0.9.18.orig/irdaping/Makefile
+++ irda-utils-0.9.18/irdaping/Makefile
@@ -56,7 +56,7 @@ all: $(TARGETS)
-
+
irdaping: $(OBJS)
- $(prn_cc_o)
+ $(prn_cc_o)
- $(ECMD)$(CC) $(CFLAGS) $(OBJS) -o $@
+ $(ECMD)$(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) -o $@
-
-
+
+
.c.o:
+Index: irda-utils-0.9.18/irnetd/Makefile
+===================================================================
--- irda-utils-0.9.18.orig/irnetd/Makefile
+++ irda-utils-0.9.18/irnetd/Makefile
@@ -50,7 +50,7 @@ all: $(TARGETS)
-
+
irnetd: $(OBJS)
- $(prn_cc_o)
+ $(prn_cc_o)
- $(ECMD)$(CC) $(CFLAGS) $(OBJS) -o $@
+ $(ECMD)$(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) -o $@
-
-
+
+
install: irnetd
+Index: irda-utils-0.9.18/psion/Makefile
+===================================================================
--- irda-utils-0.9.18.orig/psion/Makefile
+++ irda-utils-0.9.18/psion/Makefile
@@ -25,4 +25,4 @@ install: $(PSION_TARGETS)
CFLAGS += -g -I../include -Wall -Wstrict-prototypes $(RPM_OPT_FLAGS)
- irpsion5:
- $(prn_cc_o)
+ irpsion5:
+ $(prn_cc_o)
- $(ECMD)$(CC) $(CFLAGS) $(PSION_SRC) -o $@
\ No newline at end of file
+ $(ECMD)$(CC) $(CFLAGS) $(LDFLAGS) $(PSION_SRC) -o $@