summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-09 20:55:55 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-11 06:25:21 -0700
commit9f77858360b33de6c4f66638fea8a8051fb6208f (patch)
treea2b729a1b80b0bed231f736d064b30615b145ad0
parent44e650f961888b75797da8ecc23654f672c5fae6 (diff)
downloadopenembedded-core-9f77858360b33de6c4f66638fea8a8051fb6208f.tar.gz
tcf-agent: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/tcf-agent/tcf-agent/fix_ranlib.patch14
1 files changed, 8 insertions, 6 deletions
diff --git a/meta/recipes-devtools/tcf-agent/tcf-agent/fix_ranlib.patch b/meta/recipes-devtools/tcf-agent/tcf-agent/fix_ranlib.patch
index 5d704567c8..b66f41ad28 100644
--- a/meta/recipes-devtools/tcf-agent/tcf-agent/fix_ranlib.patch
+++ b/meta/recipes-devtools/tcf-agent/tcf-agent/fix_ranlib.patch
@@ -1,14 +1,16 @@
Upstream-Status: Inappropriate [poky-specific fix]
---- a/Makefile.inc
-+++ b/Makefile.inc
-@@ -57,6 +57,9 @@
- ifeq ($(NO_UUID),)
- LIBS += -luuid
+Index: agent/Makefile.inc
+===================================================================
+--- agent.orig/Makefile.inc
++++ agent/Makefile.inc
+@@ -88,6 +88,9 @@ ifneq ($(OPSYS),Windows)
+ ifneq ($(CC),g++)
+ OPTS += -Wmissing-prototypes
endif
+ ifneq ($(RANLIB),)
+ RANLIB += $@
+ endif
endif
- ifneq ($(OPSYS),Windows)
+ # Compiler flags definition