summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-10 19:30:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-14 11:41:12 +0100
commit908f6f2ded18d5301f428e685bface60335bd791 (patch)
tree45bd4a0b8bf2f1640a7ff4d3a1a39c01db917cd1
parente66f1c830bfee09ed9a043ade5374fe61fea3c99 (diff)
downloadopenembedded-core-908f6f2ded18d5301f428e685bface60335bd791.tar.gz
recipes-graphics: add x11 to REQUIRED_DISTRO_FEATURES
They can't be built withou x11 in DISTRO_FEATURES. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-graphics/libepoxy/libepoxy_1.2.bb5
-rw-r--r--meta/recipes-graphics/libfakekey/libfakekey_git.bb5
-rw-r--r--meta/recipes-graphics/waffle/waffle_1.3.0.bb5
-rw-r--r--meta/recipes-graphics/xorg-font/xorg-font-common.inc6
-rw-r--r--meta/recipes-graphics/xorg-font/xorg-minimal-fonts.bb5
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb.inc5
-rw-r--r--meta/recipes-graphics/xorg-lib/xcb-util.inc4
-rw-r--r--meta/recipes-graphics/xvideo-tests/xvideo-tests_git.bb5
8 files changed, 32 insertions, 8 deletions
diff --git a/meta/recipes-graphics/libepoxy/libepoxy_1.2.bb b/meta/recipes-graphics/libepoxy/libepoxy_1.2.bb
index 4fbc861066..1934fae943 100644
--- a/meta/recipes-graphics/libepoxy/libepoxy_1.2.bb
+++ b/meta/recipes-graphics/libepoxy/libepoxy_1.2.bb
@@ -11,6 +11,9 @@ SRCREV="7422de5b4be7b19d789136b3bb5f932de42db27c"
S = "${WORKDIR}/git"
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+
+# The virtual/libx11 requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
DEPENDS = "util-macros virtual/egl virtual/libx11"
diff --git a/meta/recipes-graphics/libfakekey/libfakekey_git.bb b/meta/recipes-graphics/libfakekey/libfakekey_git.bb
index 862fe38de2..c60ddea74d 100644
--- a/meta/recipes-graphics/libfakekey/libfakekey_git.bb
+++ b/meta/recipes-graphics/libfakekey/libfakekey_git.bb
@@ -17,4 +17,7 @@ SRC_URI = "git://git.yoctoproject.org/${BPN}"
S = "${WORKDIR}/git"
-inherit autotools pkgconfig gettext
+inherit autotools pkgconfig gettext distro_features_check
+
+# The libxtst requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/meta/recipes-graphics/waffle/waffle_1.3.0.bb b/meta/recipes-graphics/waffle/waffle_1.3.0.bb
index fe9609c5b0..a21fcbb302 100644
--- a/meta/recipes-graphics/waffle/waffle_1.3.0.bb
+++ b/meta/recipes-graphics/waffle/waffle_1.3.0.bb
@@ -7,12 +7,15 @@ SRC_URI = "http://people.freedesktop.org/~chadversary/waffle/files/release/${BPN
SRC_URI[md5sum] = "5020ecc249096c881e1f59ee961f3d41"
SRC_URI[sha256sum] = "340ee04172dba878249469018cd7ec9d1ecd41af26b612c741b8b52e713bca8e"
-inherit cmake
+inherit cmake distro_features_check
# This should be overridden per-machine to reflect the capabilities of the GL
# stack.
PACKAGECONFIG ??= "glx"
+# libx11 requires x11 in DISTRO_FEATURES.
+REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'glx', 'x11', '', d)}"
+
# I say virtual/libgl, actually wants gl.pc
PACKAGECONFIG[glx] = "-Dwaffle_has_glx=1,,virtual/libgl libx11"
diff --git a/meta/recipes-graphics/xorg-font/xorg-font-common.inc b/meta/recipes-graphics/xorg-font/xorg-font-common.inc
index d3b995a358..d5267f59a2 100644
--- a/meta/recipes-graphics/xorg-font/xorg-font-common.inc
+++ b/meta/recipes-graphics/xorg-font/xorg-font-common.inc
@@ -10,10 +10,14 @@ RDEPENDS_${PN} = "encodings font-util font-alias"
XORG_PN = "${BPN}"
INC_PR = "r2"
+
SRC_URI = "${XORG_MIRROR}/individual/font/${XORG_PN}-${PV}.tar.bz2"
S = "${WORKDIR}/${XORG_PN}-${PV}"
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+
+# The mkfontscale-native requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
EXTRA_OEMAKE += "FCCACHE=/bin/true UTIL_DIR=${STAGING_DIR_TARGET}\$\(MAPFILES_PATH\)"
diff --git a/meta/recipes-graphics/xorg-font/xorg-minimal-fonts.bb b/meta/recipes-graphics/xorg-font/xorg-minimal-fonts.bb
index bee500b43a..9bcd1b2fa6 100644
--- a/meta/recipes-graphics/xorg-font/xorg-minimal-fonts.bb
+++ b/meta/recipes-graphics/xorg-font/xorg-minimal-fonts.bb
@@ -13,7 +13,10 @@ SRC_URI = "file://misc"
PE = "1"
PR = "r2"
-inherit allarch
+inherit allarch distro_features_check
+
+# The font-alias requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
S = "${WORKDIR}/misc"
diff --git a/meta/recipes-graphics/xorg-lib/libxcb.inc b/meta/recipes-graphics/xorg-lib/libxcb.inc
index 453f5500c3..fe31f20df0 100644
--- a/meta/recipes-graphics/xorg-lib/libxcb.inc
+++ b/meta/recipes-graphics/xorg-lib/libxcb.inc
@@ -20,7 +20,10 @@ PACKAGES_DYNAMIC = "^libxcb-.*"
FILES_${PN} = "${libdir}/libxcb.so.*"
-inherit autotools pkgconfig pythonnative
+inherit autotools pkgconfig pythonnative distro_features_check
+
+# The libxau and others requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
python populate_packages_prepend () {
do_split_packages(d, '${libdir}', '^libxcb-(.*)\.so\..*$', 'libxcb-%s', 'XCB library module for %s', allow_links=True)
diff --git a/meta/recipes-graphics/xorg-lib/xcb-util.inc b/meta/recipes-graphics/xorg-lib/xcb-util.inc
index d15cf9fba1..99d04f9d44 100644
--- a/meta/recipes-graphics/xorg-lib/xcb-util.inc
+++ b/meta/recipes-graphics/xorg-lib/xcb-util.inc
@@ -18,4 +18,6 @@ DEPENDS += "gperf-native"
SRC_URI = "http://xcb.freedesktop.org/dist/${BPN}-${PV}.tar.bz2"
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/meta/recipes-graphics/xvideo-tests/xvideo-tests_git.bb b/meta/recipes-graphics/xvideo-tests/xvideo-tests_git.bb
index 27aacde837..9b3c9e0c05 100644
--- a/meta/recipes-graphics/xvideo-tests/xvideo-tests_git.bb
+++ b/meta/recipes-graphics/xvideo-tests/xvideo-tests_git.bb
@@ -11,4 +11,7 @@ SRC_URI = "git://git.yoctoproject.org/test-xvideo"
S = "${WORKDIR}/git"
-inherit autotools
+inherit autotools distro_features_check
+
+# The libxv requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"