summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-06-08 14:50:27 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-15 11:09:40 +0100
commit8befb09eb28bb6d8884d2052cd63c2c319eceed1 (patch)
tree2a30795e996291f9468bb1a1fd627289e52deef1
parent710b93a24df6372abd6d7aa0ede8750cf4bf88b4 (diff)
downloadopenembedded-core-8befb09eb28bb6d8884d2052cd63c2c319eceed1.tar.gz
wayland: fix upstream release checking
Wayland has moved to GitLab with the result that /releases/ no longer returns a directory listing, so the upgrade detection doesn't work. The upgrade detection can scan releases.html just as well, so tell it to look there. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/wayland/wayland-protocols_1.14.bb2
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.15.0.bb2
-rw-r--r--meta/recipes-graphics/wayland/weston_4.0.0.bb2
3 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland-protocols_1.14.bb b/meta/recipes-graphics/wayland/wayland-protocols_1.14.bb
index 3393a2c797..873fcf1c28 100644
--- a/meta/recipes-graphics/wayland/wayland-protocols_1.14.bb
+++ b/meta/recipes-graphics/wayland/wayland-protocols_1.14.bb
@@ -14,6 +14,8 @@ SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
SRC_URI[md5sum] = "5d32eaf0f5d6b7da7f5ad0959e2551e6"
SRC_URI[sha256sum] = "9648896b2462b49b15a69b60f44656593c170c0e73121c890eb16d0c1d9376f6"
+UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
+
inherit allarch autotools pkgconfig
PACKAGES = "${PN}"
diff --git a/meta/recipes-graphics/wayland/wayland_1.15.0.bb b/meta/recipes-graphics/wayland/wayland_1.15.0.bb
index 788105bff8..d037dc4654 100644
--- a/meta/recipes-graphics/wayland/wayland_1.15.0.bb
+++ b/meta/recipes-graphics/wayland/wayland_1.15.0.bb
@@ -18,6 +18,8 @@ SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
SRC_URI[md5sum] = "b7393c17fdce9a8d383edab656c92fd2"
SRC_URI[sha256sum] = "eb3fbebb8559d56a80ad3753ec3db800f587329067962dbf65e14488b4b7aeb0"
+UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
+
inherit autotools pkgconfig
EXTRA_OECONF = "--disable-documentation --with-host-scanner"
diff --git a/meta/recipes-graphics/wayland/weston_4.0.0.bb b/meta/recipes-graphics/wayland/weston_4.0.0.bb
index 7dfca7fc63..e78b0d9194 100644
--- a/meta/recipes-graphics/wayland/weston_4.0.0.bb
+++ b/meta/recipes-graphics/wayland/weston_4.0.0.bb
@@ -15,6 +15,8 @@ SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
SRC_URI[md5sum] = "33709aa4d5916f89643fca0fc0064b39"
SRC_URI[sha256sum] = "a0fc0ae7ef83dfbed12abfe9b8096a24a7dd00705e86fa0db1e619ded18b4b58"
+UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
+
inherit autotools pkgconfig useradd distro_features_check
# depends on virtual/egl
REQUIRED_DISTRO_FEATURES = "opengl"