summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2018-10-30 14:32:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-06 12:14:05 +0000
commit786322ec408e2ef5cd6fb809456e0453e5f5e162 (patch)
treec4f23b1aeb4d9ae824ba11d656ecb8c2157e838b
parented5e7541677f6a046f85389cd0c879be3db422cd (diff)
downloadopenembedded-core-786322ec408e2ef5cd6fb809456e0453e5f5e162.tar.gz
go-dep: disable PTEST_ENABLED for mips and mips64
The current go-dep does not compile ptest successfully on mips and mips64. So as a workaround, disable PTEST_ENABLED explicitly to avoid error like below. | vet config not found Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/go/go-dep_0.5.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-dep_0.5.0.bb b/meta/recipes-devtools/go/go-dep_0.5.0.bb
index f0ce60a8ec..cfc2186b31 100644
--- a/meta/recipes-devtools/go/go-dep_0.5.0.bb
+++ b/meta/recipes-devtools/go/go-dep_0.5.0.bb
@@ -28,3 +28,8 @@ INSANE_SKIP_${PN} += "textrel"
# http://errors.yoctoproject.org/Errors/Details/185632/
# ERROR: QA Issue: ELF binary '/work/aarch64-oe-linux/go-dep/0.4.1-r0/packages-split/go-dep-ptest/usr/lib/go-dep/ptest/github.com/golang/dep/cmd/dep/dep.test' has relocations in .text [textrel]
INSANE_SKIP_${PN}-ptest += "textrel"
+
+# For compiling ptest on mips and mips64, the current go-dep version fails with the go 1.11 toolchain.
+# error message: vet config not found
+PTEST_ENABLED_mips = "0"
+PTEST_ENABLED_mips64 = "0"