summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-03-09 12:29:06 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-11 06:25:19 -0700
commit784f4418259fe441060c134a7dcf305f4e0d4e2d (patch)
treeb30238f706ad17b4b3e561d5c8d12fdbfa4468cb
parent1e4e58d51498101e1e1b36fd4c3ad51052c15a6a (diff)
downloadopenembedded-core-784f4418259fe441060c134a7dcf305f4e0d4e2d.tar.gz
liburcu: Explicitly add pthread options to cflags
Some architectures e.g. riscv gcc does not add -D_REENTRANT when enabling pthreads. Help it here by adding these options while gcc gets fixed Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-support/liburcu/liburcu_0.10.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-support/liburcu/liburcu_0.10.1.bb b/meta/recipes-support/liburcu/liburcu_0.10.1.bb
index 0c8cd3571a..459c04a7a1 100644
--- a/meta/recipes-support/liburcu/liburcu_0.10.1.bb
+++ b/meta/recipes-support/liburcu/liburcu_0.10.1.bb
@@ -15,3 +15,5 @@ SRC_URI[sha256sum] = "9c09220be4435dc27fcd22d291707b94b97f159e0c442fbcd60c168f8f
S = "${WORKDIR}/userspace-rcu-${PV}"
inherit autotools
+
+CPPFLAGS_append_riscv64 = " -pthread -D_REENTRANT"