summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2018-09-05 13:16:57 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-06 10:36:25 +0100
commit715180e41884393d4f2f234dd557df61a21c4745 (patch)
tree2543d417ecbdc5c2ea0a01c14f1b4b3227e83039
parenta6e62aae8f83696755828631e5ff67a579a6462f (diff)
downloadopenembedded-core-715180e41884393d4f2f234dd557df61a21c4745.tar.gz
opkg: add strict package matching on removal patch
During removal, opkg is using globs to select which metadata files to remove. The glob is too broad and sometimes can result in a package removing the metadata from a package with a close name. Make the matching more strict. Fixes bugzilla 12905 Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/opkg/opkg/0001-remove_maintainer_scripts-use-strict-matching.patch56
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.3.6.bb1
2 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg/0001-remove_maintainer_scripts-use-strict-matching.patch b/meta/recipes-devtools/opkg/opkg/0001-remove_maintainer_scripts-use-strict-matching.patch
new file mode 100644
index 0000000000..ec160290be
--- /dev/null
+++ b/meta/recipes-devtools/opkg/opkg/0001-remove_maintainer_scripts-use-strict-matching.patch
@@ -0,0 +1,56 @@
+From 55c4ad666e76281bdd0db55fa6f4ab2744fea7e4 Mon Sep 17 00:00:00 2001
+From: Alejandro del Castillo <alejandro.delcastillo@ni.com>
+Date: Tue, 4 Sep 2018 18:06:00 -0500
+Subject: [PATCH] remove_maintainer_scripts: use strict matching
+
+The function is using a glob to select which metadata files needs to be
+deleted during package removal, on the info_dir. However, the glob may
+match metadata files from packages with similar names. For example,
+during removal of package glibc-binary-localedata-de-at, the current
+logic was also removing the metadata for
+glibc-binary-localedata-de-at.iso-8859-1. Add check for an exact match
+before deletion.
+
+Fixes bugzilla: 12905
+
+Upstream-Status: Submitted [https://groups.google.com/forum/#!topic/opkg-devel/Fr40Yt0NBno]
+Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com>
+---
+ libopkg/opkg_remove.c | 14 +++++++++++---
+ 1 file changed, 11 insertions(+), 3 deletions(-)
+
+diff --git a/libopkg/opkg_remove.c b/libopkg/opkg_remove.c
+index 82125fa..3936628 100644
+--- a/libopkg/opkg_remove.c
++++ b/libopkg/opkg_remove.c
+@@ -137,7 +137,7 @@ void remove_maintainer_scripts(pkg_t * pkg)
+ {
+ unsigned int i;
+ int err;
+- char *globpattern;
++ char *globpattern, *filename, *lastdot;
+ glob_t globbuf;
+
+ if (opkg_config->noaction)
+@@ -151,8 +151,16 @@ void remove_maintainer_scripts(pkg_t * pkg)
+ return;
+
+ for (i = 0; i < globbuf.gl_pathc; i++) {
+- opkg_msg(INFO, "Deleting %s.\n", globbuf.gl_pathv[i]);
+- unlink(globbuf.gl_pathv[i]);
++ filename = xstrdup(basename(globbuf.gl_pathv[i]));
++ lastdot = strrchr(filename, '.');
++ *lastdot = '\0';
++ // Only delete files that match the package name (the glob may match files
++ // with similar names)
++ if (!strcmp(filename, pkg->name)) {
++ opkg_msg(INFO, "Deleting %s.\n", globbuf.gl_pathv[i]);
++ unlink(globbuf.gl_pathv[i]);
++ }
++ free(filename);
+ }
+ globfree(&globbuf);
+ }
+--
+2.18.0
+
diff --git a/meta/recipes-devtools/opkg/opkg_0.3.6.bb b/meta/recipes-devtools/opkg/opkg_0.3.6.bb
index 579b51166c..6ebd58b967 100644
--- a/meta/recipes-devtools/opkg/opkg_0.3.6.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.3.6.bb
@@ -14,6 +14,7 @@ PE = "1"
SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
file://opkg.conf \
file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \
+ file://0001-remove_maintainer_scripts-use-strict-matching.patch \
"
SRC_URI[md5sum] = "79e04307f6f54db431c251772d7d987c"