summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Madison <matt@madison.systems>2021-09-25 04:00:38 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-09-26 14:34:51 +0100
commit60af398f520c938600205ef40e27f90e5342209c (patch)
tree0be16b695aa77402af8769119e0a31811d858d0b
parent0882095d608ce3abbcc9814517434c21ea549063 (diff)
downloadopenembedded-core-60af398f520c938600205ef40e27f90e5342209c.tar.gz
autotools.bbclass: use ordinary append for file-checksums update
Commit 29daffc2410f06f36b779d5bf1fd1ef6e900ca8f added an anonymous python function to append the site file dependencies for do_configure. This causes any recipe that inherits allarch after autotools to end up with a different set of file checksums for each machine, since the anonymous python would get processed before the TARGET_ARCH changes in allarch. Use an ordinary += assignment to fix this. Signed-off-by: Matt Madison <matt@madison.systems> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/classes/autotools.bbclass5
1 files changed, 1 insertions, 4 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index bc0c2ea83e..4ab2460990 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -149,10 +149,7 @@ python autotools_aclocals () {
d.setVar("CONFIG_SITE", " ".join(sitefiles))
}
-python () {
- sitefiles, searched = siteinfo_get_files(d, sysrootcache=False)
- d.appendVarFlag("do_configure", "file-checksums", " " + " ".join(searched))
-}
+do_configure[file-checksums] += "${@' '.join(siteinfo_get_files(d, sysrootcache=False)[1])}"
CONFIGURE_FILES = "${S}/configure.in ${S}/configure.ac ${S}/config.h.in ${S}/acinclude.m4 Makefile.am"