summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorConstantin Musca <constantinx.musca@intel.com>2013-02-04 11:20:15 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-04 16:40:52 +0000
commit6039e0048d324569620868ec774cd88aa191eeaf (patch)
tree8b88f591d529fd13eb2ebe47eefa6b172f2b4f58
parent3300d5fdcc60b14e184e0c6c40ba25d8c4d5ed46 (diff)
downloadopenembedded-core-6039e0048d324569620868ec774cd88aa191eeaf.tar.gz
enchant: use BPN instead of PN
- use BPN (PN includes mlprefix) to package all files when building with multilib options [YOCTO #3438] Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/enchant/enchant_1.6.0.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-support/enchant/enchant_1.6.0.bb b/meta/recipes-support/enchant/enchant_1.6.0.bb
index 25178f57c8..c16a2a816a 100644
--- a/meta/recipes-support/enchant/enchant_1.6.0.bb
+++ b/meta/recipes-support/enchant/enchant_1.6.0.bb
@@ -10,7 +10,7 @@ RDEPENDS_${PN} = "aspell"
inherit autotools pkgconfig
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.abisource.com/downloads/enchant/${PV}/enchant-${PV}.tar.gz"
@@ -19,8 +19,8 @@ SRC_URI[sha256sum] = "2fac9e7be7e9424b2c5570d8affe568db39f7572c10ed48d4e13cddf03
EXTRA_OECONF = "--with-aspell-prefix=${STAGING_DIR_HOST}${prefix} --enable-aspell --disable-binreloc"
-FILES_${PN} = "${bindir} ${libdir}/*${SOLIBS} ${datadir}/${PN} ${libdir}/${PN}/*.so"
-FILES_${PN}-dev += "${libdir}/${PN}/*{SOLIBSDEV} ${libdir}/${PN}/*.la"
-FILES_${PN}-staticdev += "${libdir}/${PN}/*.a"
+FILES_${PN} = "${bindir} ${libdir}/*${SOLIBS} ${datadir}/${BPN} ${libdir}/${BPN}/*.so"
+FILES_${PN}-dev += "${libdir}/${BPN}/*{SOLIBSDEV} ${libdir}/${BPN}/*.la"
+FILES_${PN}-staticdev += "${libdir}/${BPN}/*.a"
export CXXFLAGS += " -L${STAGING_LIBDIR} -lstdc++ "