summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2012-01-25 18:22:33 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-01 14:58:45 +0000
commit4ccae37db1aa77a1d15098c3720ea6e2d383fbdc (patch)
treef9d371d389b87e6882f0bb858629a5f24158a380
parentdf5e886be059da35fb69710c79227cc768f1c58e (diff)
downloadopenembedded-core-4ccae37db1aa77a1d15098c3720ea6e2d383fbdc.tar.gz
qt4-tools-nativesdk-4.8.0: fix build
the build is actually failing because host g++ and ld are used to compile and link Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--meta/recipes-qt/qt4/qt-4.7.4/configure-lflags.patch (renamed from meta/recipes-qt/qt4/files/configure-lflags.patch)0
-rw-r--r--meta/recipes-qt/qt4/qt-4.8.0/configure-lflags.patch18
-rw-r--r--meta/recipes-qt/qt4/qt4-tools-nativesdk.inc10
-rw-r--r--meta/recipes-qt/qt4/qt4-tools-nativesdk_4.7.4.bb3
4 files changed, 27 insertions, 4 deletions
diff --git a/meta/recipes-qt/qt4/files/configure-lflags.patch b/meta/recipes-qt/qt4/qt-4.7.4/configure-lflags.patch
index a8e5945975..a8e5945975 100644
--- a/meta/recipes-qt/qt4/files/configure-lflags.patch
+++ b/meta/recipes-qt/qt4/qt-4.7.4/configure-lflags.patch
diff --git a/meta/recipes-qt/qt4/qt-4.8.0/configure-lflags.patch b/meta/recipes-qt/qt4/qt-4.8.0/configure-lflags.patch
new file mode 100644
index 0000000000..d74f7fde1a
--- /dev/null
+++ b/meta/recipes-qt/qt4/qt-4.8.0/configure-lflags.patch
@@ -0,0 +1,18 @@
+qt4-tools-native: set LFLAGS to pick up zlib from staging
+
+Original Author: Jeremy Lainé <jeremy.laine@m4x.org>
+Upstream-Status: Pending
+
+Index: qt-everywhere-opensource-src-4.8.0/configure
+===================================================================
+--- qt-everywhere-opensource-src-4.8.0.orig/configure
++++ qt-everywhere-opensource-src-4.8.0/configure
+@@ -611,7 +611,7 @@ fi
+ # initalize variables
+ #-------------------------------------------------------------------------------
+
+-SYSTEM_VARIABLES="RANLIB STRIP OBJDUMP LD CC CXX CFLAGS CXXFLAGS LDFLAGS"
++SYSTEM_VARIABLES="RANLIB STRIP OBJDUMP LD CC CXX CFLAGS CXXFLAGS LDFLAGS LFLAGS"
+ for varname in $SYSTEM_VARIABLES; do
+ qmakevarname="${varname}"
+ # use LDFLAGS for autoconf compat, but qmake uses QMAKE_LFLAGS
diff --git a/meta/recipes-qt/qt4/qt4-tools-nativesdk.inc b/meta/recipes-qt/qt4/qt4-tools-nativesdk.inc
index 275fdcc68c..4b097cf4d9 100644
--- a/meta/recipes-qt/qt4/qt4-tools-nativesdk.inc
+++ b/meta/recipes-qt/qt4/qt4-tools-nativesdk.inc
@@ -4,7 +4,7 @@ SECTION = "libs"
HOMEPAGE = "http://qt.nokia.com"
LICENSE = "LGPLv2.1 | GPLv3"
-INC_PR = "r7"
+INC_PR = "r8"
FILESEXTRAPATHS =. "${FILE_DIRNAME}/qt-${PV}:"
@@ -12,7 +12,6 @@ inherit nativesdk qmake2
SRC_URI = "http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-${PV}.tar.gz \
file://configure-lflags.patch \
- file://compile.test-lflags.patch \
file://qt-config.patch \
file://qmake-exists-check.patch \
file://configure-paths.patch \
@@ -51,12 +50,18 @@ EXTRA_OECONF = "-prefix ${prefix} \
EXTRA_OEMAKE = " "
do_configure() {
+ # Avoid problems with Qt 4.8.0 configure setting QMAKE_LINK from LD (since we want the linker to be g++)
+ unset LD
+
if [ ! -e mkspecs/${TARGET_OS}-oe-g++ ]; then
ln -sf linux-g++ mkspecs/${TARGET_OS}-oe-g++
fi
cp ../g++.conf mkspecs/common
cp ../linux.conf mkspecs/common
+ # don't use host g++ even during configure
+ sed -i -e "s#g++#${CXX}#" mkspecs/common/g++-base.conf
+ sed -i -e "s#gcc#${CC}#" mkspecs/common/g++-base.conf
# first launch configure to get qmake compiled for the nativesdk
(echo o; echo yes) | CC="${CC}" CXX="${CXX}" ./configure ${EXTRA_OECONF} || true
@@ -66,7 +71,6 @@ do_configure() {
if [ ! -e bin/qmake ]; then
ln -sf ${STAGING_BINDIR_NATIVE}/qmake2 bin/qmake
fi
-
(echo o; echo yes) | CC="${CC}" CXX="${CXX}" ./configure ${EXTRA_OECONF} || die "Configuring qt failed. EXTRA_OECONF was ${EXTRA_OECONF}"
}
diff --git a/meta/recipes-qt/qt4/qt4-tools-nativesdk_4.7.4.bb b/meta/recipes-qt/qt4/qt4-tools-nativesdk_4.7.4.bb
index 4c90d57861..ea5e13d405 100644
--- a/meta/recipes-qt/qt4/qt4-tools-nativesdk_4.7.4.bb
+++ b/meta/recipes-qt/qt4/qt4-tools-nativesdk_4.7.4.bb
@@ -3,7 +3,8 @@ require qt4-tools-nativesdk.inc
PR = "${INC_PR}.0"
SRC_URI += "file://blacklist-diginotar-certs.diff \
- file://fix-qtbug-20925.patch"
+ file://fix-qtbug-20925.patch \
+ file://compile.test-lflags.patch "
SRC_URI[md5sum] = "9831cf1dfa8d0689a06c2c54c5c65aaf"
SRC_URI[sha256sum] = "97195ebce8a46f9929fb971d9ae58326d011c4d54425389e6e936514f540221e"