summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <jpewhacker@gmail.com>2019-12-08 14:18:48 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-09 11:56:41 +0000
commit3cce2d1c36b0859186139d650fd50d2a56e91abd (patch)
tree48513bef5a4f896bec17a38da40d9f1b6acfa23a
parent53f61ca73e69508bff6ea75da666d6873b5384f5 (diff)
downloadopenembedded-core-3cce2d1c36b0859186139d650fd50d2a56e91abd.tar.gz
flex: Replace uninative loader path
The Makefile used for flex-ptest can pick up the path to the uninative loader through BUILD_LDFLAGS. This includes the full path to the uninative loader, which is not reproducible. Replace it with /bin/false. It doesn't appear as if these native programs are used in the test suites and if there are likely to be other problems related to building them using the BUILD_* flags. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/flex/flex_2.6.4.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/flex/flex_2.6.4.bb b/meta/recipes-devtools/flex/flex_2.6.4.bb
index d8e2f7f28c..43b2547fc6 100644
--- a/meta/recipes-devtools/flex/flex_2.6.4.bb
+++ b/meta/recipes-devtools/flex/flex_2.6.4.bb
@@ -64,8 +64,13 @@ do_install_ptest() {
-e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \-e 's/^Makefile:/_Makefile:/' \
-e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \
-e 's/^builddir = \(.*\)/builddir = ./' -e 's/^top_builddir = \(.*\)/top_builddir = ./' \
+ -e 's:${UNINATIVE_LOADER}:${base_bindir}/false:g' \
-i ${D}${PTEST_PATH}/Makefile
}
+# The uninative loader is different on i386 & x86_64 hosts. Since it is only
+# being replaced with /bin/false anyway, it doesn't need to be part of the task
+# hash
+do_install_ptest[vardepsexclude] += "UNINATIVE_LOADER"
# Not Apache Flex, or Adobe Flex, or IBM Flex.
CVE_PRODUCT = "flex_project:flex"