summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-06 00:08:35 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-14 11:41:11 +0100
commit3a464d67b60f70b865f7db768e7edc53e40ff450 (patch)
tree8f84cf63095065625082b88a94645c3fd64e99c8
parented72e123724599e70eb4d283f06fca3e56a8b50a (diff)
downloadopenembedded-core-3a464d67b60f70b865f7db768e7edc53e40ff450.tar.gz
mesa: fix do_install_append
"ifdef MESA_EGL_NO_X11_HEADERS" -> "if defined(MESA_EGL_NO_X11_HEADERS)" Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-graphics/mesa/mesa_10.5.4.bb2
-rw-r--r--meta/recipes-graphics/mesa/mesa_git.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_10.5.4.bb b/meta/recipes-graphics/mesa/mesa_10.5.4.bb
index 150c664ebf..03c9ecff68 100644
--- a/meta/recipes-graphics/mesa/mesa_10.5.4.bb
+++ b/meta/recipes-graphics/mesa/mesa_10.5.4.bb
@@ -9,6 +9,6 @@ SRC_URI[sha256sum] = "b51e723f3a20d842c88a92d809435b229fc4744ca0dbec0317d9d4a3ac
#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
do_install_append() {
if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
- sed -i -e 's/^#ifdef MESA_EGL_NO_X11_HEADERS/#if ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)/#if ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
fi
}
diff --git a/meta/recipes-graphics/mesa/mesa_git.bb b/meta/recipes-graphics/mesa/mesa_git.bb
index 0260617742..8f70f6721b 100644
--- a/meta/recipes-graphics/mesa/mesa_git.bb
+++ b/meta/recipes-graphics/mesa/mesa_git.bb
@@ -17,6 +17,6 @@ inherit pythonnative
#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
do_install_append() {
if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
- sed -i -e 's/^#ifdef MESA_EGL_NO_X11_HEADERS/#if ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)/#if ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
fi
}