summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <Mingli.Yu@windriver.com>2018-06-15 17:28:01 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-15 10:58:18 +0100
commit3084ff86d61b54011e0647ee17cbba521bafc9df (patch)
treee28b1d8e757e98a36ce1760290a2802e37c14df7
parent9f0570351a7b0877aa50efff5fe9a9ef368cb38f (diff)
downloadopenembedded-core-3084ff86d61b54011e0647ee17cbba521bafc9df.tar.gz
ltp: set -fomit-frame-pointer explicitly for x86-64
Since ltp contains x86-64 assembler which uses the frame-pointer register, it will trigger below error when build ltp with -fno-omit-frame-pointer on x86-64. | cve-2015-3290.c: In function 'child_thread': | cve-2015-3290.c:416:1: error: bp cannot be used in asm here And there is also some comment as below in the source file ltp/20180515-r0/git/testcases/cve/cve-2015-3290.c * Build with -O2. Don't use -fno-omit-frame-pointer. So explicitly set -fomit-frame-pointer on x86-64 for compiler to fix the above build error. Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/ltp/ltp_20180515.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp_20180515.bb b/meta/recipes-extended/ltp/ltp_20180515.bb
index b07c1b9268..21ff49830a 100644
--- a/meta/recipes-extended/ltp/ltp_20180515.bb
+++ b/meta/recipes-extended/ltp/ltp_20180515.bb
@@ -19,6 +19,13 @@ LIC_FILES_CHKSUM = "\
DEPENDS = "attr libaio libcap acl openssl zip-native"
DEPENDS_append_libc-musl = " fts "
EXTRA_OEMAKE_append_libc-musl = " LIBC=musl "
+
+# since ltp contains x86-64 assembler which uses the frame-pointer register,
+# set -fomit-frame-pointer x86-64 to handle cases where optimisation
+# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
+# earlier in CFLAGS, etc.
+CFLAGS_append_x86-64 = " -fomit-frame-pointer"
+
CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
SRCREV = "96cbf48313afa65ef4d693d3441cbfd60a8d9b27"