summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-10 19:17:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-14 11:41:11 +0100
commit1722ce23075a00e111145cad6daa2ef87ba391fe (patch)
tree68aba0e232beca1f632d13b3ee798b48af9298c8
parent777080af697d35b3f983465d6a094f4171e57e56 (diff)
downloadopenembedded-core-1722ce23075a00e111145cad6daa2ef87ba391fe.tar.gz
libowl/settings-daemon/libnotify: add x11 to REQUIRED_DISTRO_FEATURES
The libowl, settings-daemon and libnotify requires gdk/gdkx.h which is provided by gtk when x11 in DISTRO_FEATURES, so add x11 to REQUIRED_DISTRO_FEATURES. The leafpad, settings-daemon and oh-puzzles requires libowl or settings-daemon, so add xx to REQUIRED_DISTRO_FEATURES for them too. The leafpad can't be built without libowl, so depends in directly rather than use DEPENDS_append_poky. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-gnome/libnotify/libnotify_0.6.0.bb6
-rw-r--r--meta/recipes-sato/leafpad/leafpad_0.8.18.1.bb8
-rw-r--r--meta/recipes-sato/libowl/libowl_git.bb5
-rw-r--r--meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_git.bb4
-rw-r--r--meta/recipes-sato/puzzles/oh-puzzles_git.bb9
-rw-r--r--meta/recipes-sato/settings-daemon/settings-daemon_git.bb5
6 files changed, 28 insertions, 9 deletions
diff --git a/meta/recipes-gnome/libnotify/libnotify_0.6.0.bb b/meta/recipes-gnome/libnotify/libnotify_0.6.0.bb
index 1d92b6482f..e6ee89bd01 100644
--- a/meta/recipes-gnome/libnotify/libnotify_0.6.0.bb
+++ b/meta/recipes-gnome/libnotify/libnotify_0.6.0.bb
@@ -7,7 +7,11 @@ PR = "r1"
DEPENDS = "dbus gtk+ dbus-glib"
-inherit gnomebase
+inherit gnomebase distro_features_check
+
+# Requires gdk/gdkx.h which is provided by gtk when x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
+
SRC_URI[archive.md5sum] = "732c9d2cd5eb6a9069264a319d330516"
SRC_URI[archive.sha256sum] = "73b16a79bb2fed62dcf146b11c4405776cb96a09dce66379ca541da7dbd64210"
diff --git a/meta/recipes-sato/leafpad/leafpad_0.8.18.1.bb b/meta/recipes-sato/leafpad/leafpad_0.8.18.1.bb
index 830c053b6b..f71514916b 100644
--- a/meta/recipes-sato/leafpad/leafpad_0.8.18.1.bb
+++ b/meta/recipes-sato/leafpad/leafpad_0.8.18.1.bb
@@ -6,8 +6,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://src/leafpad.h;endline=20;md5=d3d6a89f5e61e8b13bdea537511ba1fa \
file://src/utils.c;endline=20;md5=0d2cc6584ba3202448bb274f62739571"
-DEPENDS = "gtk+ intltool-native"
-DEPENDS_append_poky = " libowl"
+DEPENDS = "gtk+ intltool-native libowl"
+# The libowl requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
+
SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \
file://leafpad.desktop"
@@ -17,7 +19,7 @@ PR = "r2"
SRC_URI_append_poky = " file://owl-menu.patch;apply=yes "
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
EXTRA_OECONF = " --enable-chooser --disable-emacs --disable-print"
diff --git a/meta/recipes-sato/libowl/libowl_git.bb b/meta/recipes-sato/libowl/libowl_git.bb
index 3ccd3406bd..9cc47dbd53 100644
--- a/meta/recipes-sato/libowl/libowl_git.bb
+++ b/meta/recipes-sato/libowl/libowl_git.bb
@@ -17,4 +17,7 @@ SRC_URI = "git://git.yoctoproject.org/${BPN}"
S = "${WORKDIR}/git"
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+
+# Requires gdk/gdkx.h which is provided by gtk when x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_git.bb b/meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_git.bb
index f0119b7073..5f73a4c48d 100644
--- a/meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_git.bb
+++ b/meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_git.bb
@@ -17,5 +17,7 @@ S = "${WORKDIR}/git"
SRC_URI = "git://git.yoctoproject.org/${BPN} \
file://no-handed.patch;striplevel=0"
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+# The settings-daemon requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/meta/recipes-sato/puzzles/oh-puzzles_git.bb b/meta/recipes-sato/puzzles/oh-puzzles_git.bb
index bd762e9315..36cd2cc7a2 100644
--- a/meta/recipes-sato/puzzles/oh-puzzles_git.bb
+++ b/meta/recipes-sato/puzzles/oh-puzzles_git.bb
@@ -9,7 +9,12 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=f56ec6772dd1c7c367067bbea8ea1675 \
SECTION = "x11"
DEPENDS = "gtk+ gconf intltool-native librsvg"
-DEPENDS_append_poky = " libowl"
+
+# libowl requires x11 in DISTRO_FEATURES
+DEPENDS_append_poky = " ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libowl', '', d)}"
+
+# Requires gdk/gdkx.h which is provided by gtk when x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
SRCREV = "92f1a20e4b72eed7a35b00984d9793b51dc2fb3b"
PV = "0.2+git${SRCPV}"
@@ -20,7 +25,7 @@ SRC_URI_append_poky = " file://oh-puzzles-owl-menu.patch;striplevel=0 "
S = "${WORKDIR}/git"
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
bindir = "/usr/games"
diff --git a/meta/recipes-sato/settings-daemon/settings-daemon_git.bb b/meta/recipes-sato/settings-daemon/settings-daemon_git.bb
index ba48d90773..c0615530af 100644
--- a/meta/recipes-sato/settings-daemon/settings-daemon_git.bb
+++ b/meta/recipes-sato/settings-daemon/settings-daemon_git.bb
@@ -17,10 +17,13 @@ SRC_URI = "git://git.yoctoproject.org/xsettings-daemon \
S = "${WORKDIR}/git"
-inherit autotools pkgconfig gconf
+inherit autotools pkgconfig gconf distro_features_check
FILES_${PN} = "${bindir}/* ${sysconfdir}"
+# Requires gdk-x11-2.0 which is provided by gtk when x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
+
do_install_append () {
install -d ${D}/${sysconfdir}/X11/Xsession.d
install -m 755 ${WORKDIR}/70settings-daemon.sh ${D}/${sysconfdir}/X11/Xsession.d/