summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2019-04-11 15:02:32 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-11 21:19:27 +0100
commit55acc9b477919208d91781dbe9a03136f895a94b (patch)
tree0b67ea80379a67246c827d3bafad104f31a9d8f6
parent5bad5eb5f41053e4963fb26972f56dbf67349378 (diff)
downloadopenembedded-core-55acc9b477919208d91781dbe9a03136f895a94b.tar.gz
ruby: make ext module fiddle can compile success
ext module fiddle depend on libffi, in ruby source tree, there is in internal libffi in case target platfrom don't install libffi, but autotools.bbclass delete configure under libffi and not run autoreconf to regenerate one.so we met this error: ruby-2.5.3/ext/fiddle/libffi-3.2.1/configure: No such file or directory the fix is add depend and extra_oeconf to use libffi in the system Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/ruby/ruby.inc2
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.5.3.bb1
2 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/ruby/ruby.inc b/meta/recipes-devtools/ruby/ruby.inc
index eaf5d13ac2..28e21fee9c 100644
--- a/meta/recipes-devtools/ruby/ruby.inc
+++ b/meta/recipes-devtools/ruby/ruby.inc
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "\
file://LEGAL;md5=23a79bb4c1a40f6cc9bcb6f4e7c39799 \
"
-DEPENDS = "ruby-native zlib openssl tcl libyaml gdbm readline"
+DEPENDS = "ruby-native zlib openssl tcl libyaml gdbm readline libffi"
DEPENDS_class-native = "openssl-native libyaml-native readline-native"
SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}"
diff --git a/meta/recipes-devtools/ruby/ruby_2.5.3.bb b/meta/recipes-devtools/ruby/ruby_2.5.3.bb
index 3fb427e90e..173b44b377 100644
--- a/meta/recipes-devtools/ruby/ruby_2.5.3.bb
+++ b/meta/recipes-devtools/ruby/ruby_2.5.3.bb
@@ -28,6 +28,7 @@ EXTRA_OECONF = "\
--disable-dtrace \
--enable-shared \
--enable-load-relative \
+ --with-pkg-config=pkg-config \
"
do_install() {